[mythtv] Ticket #13326: DVD Playback fails in master

Peter Bennett pb.mythtv at gmail.com
Sun Oct 14 18:50:26 UTC 2018

On 10/14/2018 02:05 PM, MythTV wrote:
> #13326: DVD Playback fails in master
> -----------------------------------+-------------------------------
>   Reporter:  Peter Bennett          |          Owner:  Peter Bennett
>       Type:  Patch - Bug Fix        |         Status:  closed
>   Priority:  minor                  |      Milestone:  30.0
> Component:  MythTV - DVD Playback  |        Version:  Master Head
>   Severity:  medium                 |     Resolution:  Fixed
>   Keywords:                         |  Ticket locked:  0
> -----------------------------------+-------------------------------
> Comment (by jpilk):
>   I hadn't been conscious of DVD playback problems in MythTV, although I
>   have a large collection of MythArchive creations.  I suppose mostly they
>   have been played back, if at all, on other systems and any problems were
>   just accepted as part of the DVD experiemce.  They weren't frequent.
>   But I just took a random example and tried it with F27 master cc60867 with
>   nvidia 396.54 VDPAU High Quality, and playback consistently fails at one
>   position:
>   Player(0): waiting for video buffers
>   followed by sequences of
>   Player(0): Waited xxxx ms for video buffers <diagnostic code value>
>   Eventually it quits with 'Video frame buffering failed too many times'
>   I also see 'DVDRB: Failed to read block: Error reading from DVD' but that
>   might be after some button pushes.
>   VLC 3.0.4 seemed to cope ok, and MythTV played a K3b-recovered .iso image,
>   as a Video, without problems. My disks are burned from an image including
>   checkisomd5, and the recovered image is good.
>   F27 real DVD playback fails at the same point on this disk for VDPAU HD or
>   Normal, or just Normal.
>   Playing the same disk is OK on the el7 box at master 11d426bd49b with old
>   intel q33 graphics.
>   I've just reverted on F27 to 4651002fc0c and VDPAU HQ.  That fails too.
>   I don't know how many of my disks might be affected by this...

What type of DVD is it? If it is a commercial DVD (encrypted) you need 
the decryption stuff, which is, on Ubuntu:


I tested with commercial DVDs : The Sound of Music. That plays fine on 
cc60867b307 on my system, before the two commits it would not play. I 
also tried Doctor Zhivago. Everything works on my system.

I tested vaapi2, opengl, normal, vdpau.

Does your system play anything at all? Does it fail at the beginning or 
in the middle of a 90 minute movie? Do you see the menus?


More information about the mythtv-dev mailing list