[mythtv] Anisable

Bill Meek keemllib at gmail.com
Wed Dec 5 15:18:22 UTC 2018


On 12/5/18 6:19 AM, jam at tigger.ws wrote:
> Hi
> I’m trying to use anisable on suse leap 15.0 with  not good results.
> 
> Make sense to anyone?
> (And the retry is no better
> But package python-MySQL-python actually does not exist)
> Thanks
> James
> 
> TASK [mythtv-suse : install packages] **********************************************************************
> fatal: [localhost]: FAILED! => {"changed": false, "cmd": ["/usr/bin/zypper", "--quiet", "--non-interactive", "--xmlout", "install", "--type", "package", "--auto-agree-with-licenses", "--no-recommends", "--", "+gcc-c++", "+yasm", "+ccache", "+libxml2-devel", "+alsa-devel", "+avahi-compat-mDNSResponder-devel", "+libexiv2-devel", "+libbluray-devel", "+lzo-devel", "+libhdhomerun-devel", "+libsamplerate-devel", "+libXinerama-devel", "+libXrandr-devel", "+libXv-devel", "+libva-devel", "+libva-gl-devel", "+libvdpau-devel", "+libcec-devel", "+libass-devel", "+libcrystalhd-devel", "+systemd-devel", "+libvpx-devel", "+libbluray-bdj", "+libmp3lame-devel", "+python-MySQL-python", "+python-lxml", "+python-urlgrabber", "+python-future", "+python-requests", "+python-oauth", "+perl-ExtUtils-MakeMaker", "+perl-DBD-mysql", "+perl-IO-Socket-INET6", "+perl-Date-Manip", "+perl-DateTime-Format-ISO8601", "+perl-SOAP-Lite", "+perl-JSON", "+perl-Image-Size", "+perl-Net-UPnP", "+libvorbis-devel", "+flac-devel", "+libtag-devel", "+libcdio-devel", "+libcdio-paranoia-devel", "+libmysqlclient-devel", "+fftw3-threads-devel", "+libexif-devel", "+dcraw", "+minizip-devel"], "msg": "Package '+python-MySQL-python' not found.", "rc": 104, "stderr": "", "stderr_lines": [], "stdout": "<?xml version='1.0'?>\n<stream>\n<message type=\"error\">Package '+python-MySQL-python' not found.</message>\n</stream>\n", "stdout_lines": ["<?xml version='1.0'?>", "<stream>", "<message type=\"error\">Package '+python-MySQL-python' not found.</message>", "</stream>"]}
> 	to retry, use: --limit @/home/jam/ansible/qt5.retry


I'd start by commenting out the: "- python-MySQL-python" line in
.../roles/mythtv-suse/tasks/main.yml (wherever your files are
stored.) Put a # before the -. Just to see if that's the only failure.

Next, you need to find out the current name of the Python MySQL
package using whatever tools are available to search for them.

Assuming this is something unique to suse leap 15.0, then:
the output of: ansible --module-name  setup yourHostName
is needed.

The lines like these would allow us to select the package
based on the version info:

         "ansible_distribution": "Ubuntu",
         "ansible_distribution_file_variety": "Debian",
         "ansible_distribution_major_version": "16",
         "ansible_distribution_release": "xenial",
         "ansible_distribution_version": "16.04",

As you can see, I'm a *buntu user, so need your help to answer
the above.

-- 
Bill


More information about the mythtv-dev mailing list