[mythtv] ttvdb new dependencies -- Was: [mythtv-commits] mythtv branch fixes/0.28 updated by pbennett. v0.28.1-49-g172459d

Torbjörn Jansson torbjorn.jansson at mbox200.swipnet.se
Mon Oct 30 10:32:56 UTC 2017


On 30 October 2017 09:31:47 GMT+01:00, Mark Perkins <perkins1724 at hotmail.com> wrote:
>On 30 October 2017 5:50:52 pm Torbjorn Jansson 
><torbjorn.jansson at mbox200.swipnet.se> wrote:
>
>> On 2017-10-30 08:05, Torbjorn Jansson wrote:
>>> On 2017-10-30 00:50, Craig Treleaven wrote:
>>>> Hi:
>>>>
>>>> Not sure how linux distributions are packaged, but this change
>added a
>>>> dependency on some additional python modules, at least in a Python
>2.7
>>>> environment.  The new modules are:
>>>>
>>>> future
>>>> requests-cache (which then requires 4 other python modules)
>>>>
>>>> I thought it was frowned on to add new dependencies to a fixes
>branch?
>>>> Anyway, this tripped up a MacPorts user for a little while.  Fixed
>now.
>>>>
>>>> Craig
>>>>
>>>
>>> thanks this helped fix it for me too.
>>>
>>> on my fedora install i had to do:
>>> dnf install python2-future.noarch python3-future.noarch
>>> dnf install python-requests-cache.noarch
>python3-requests-cache.noarch
>>>
>>> no idea if i really needed both the 2 and 3 package but it works
>better now.
>>>
>>> without first ttvdb.py errored with:
>>> Error:(No module named builtins)
>>>
>>> and once python future was installed it errored with:
>>> Error:(No module named requests_cache)
>>>
>>> and no errors after both was installed.
>>
>> actually i might have spoken too soon.
>> running a lookup errors out with:
>>
>> Traceback (most recent call last):
>>    File "/usr/local/share/mythtv/metadata/Television/ttvdb.py", line
>2464, in
>> <module>
>>      sys.exit(main())
>>    File "/usr/local/share/mythtv/metadata/Television/ttvdb.py", line
>2169, in main
>>      userkey=tvdb_account.account_identifier)
>>    File "/usr/lib/python2.7/site-packages/MythTV/ttvdb/tvdb_api.py",
>line 693,
>> in __init__
>>      self.session.remove_expired_responses()
>>    File
>>
>"/usr/lib/python2.7/site-packages/MythTV/ttvdb/requests_cache_compatability.py",
>> line 40, in remove_expired_responses
>>      self.cache.remove_old_entries(datetime.utcnow() -
>self._cache_expire_after)
>> TypeError: unsupported operand type(s) for -: 'datetime.datetime' and
>'int'
>>
>>
>> ________________________
>
>Anything here? https://www.mythtv.org/wiki/TheTVDB_API_v2
>
>
>_______________________________________________
>mythtv-dev mailing list
>mythtv-dev at mythtv.org
>http://lists.mythtv.org/mailman/listinfo/mythtv-dev
>http://wiki.mythtv.org/Mailing_List_etiquette
>MythTV Forums: https://forum.mythtv.org
>
>
>!DSPAM:1,59f6e43714365832212107!

I got all new dependencies, only difference is the version of requests-cache.
I got 0.4.6 from fedora repository.

Is that the problem?


More information about the mythtv-dev mailing list