[mythtv] Upgrade to nVidia gt1030 - gracefully handle failing non-VDPAU modes?

Peter Bennett pgbennett at comcast.net
Fri Oct 13 02:55:29 UTC 2017



On 10/12/2017 09:48 PM, kingsley.turner wrote:
> Hi,
>
> I upgraded to a new video card the other day, a nVidia gt1030 fanless 
> (replacing a gt730 fanless).
> I bought the MSI version of this card with Display Port and HDMI, but 
> I'm using HDMI.
> I upgraded in preparation for purchasing a new TV, where even 
> lower-end Aldi models are all 4k.
>
> With the latest nVidia driver, everything is mostly working.
> However on some HEVC/x265 videos that *used* to play with the old card 
> and driver, now mythfrontend (0.28)
> pauses for a couple of seconds, then drops back with an error message 
> "Unable to Initialise A/V sync".
>
> This is (I think) a problem because the nVidia VDPAU doesn't work with 
> this type of video encoding on this model card.
>
> Is there a way I can configure mythfrontend to fallback to software 
> decoding or suchlike?
>
> Is Myth 0.29 (with updated ffmpeg) going to help solve this?  I read 
> the change-log, but it didn't cover this topic.
>
> thanks,
> -kt
>
>
MythTV V29 has a few fixes that may help.

https://code.mythtv.org/trac/ticket/12992
  - partial fix for playback of interlaced h265 on VDPAU

If that does not solve it  -
https://code.mythtv.org/trac/ticket/13061
- Allows for selection of software decoding based on the video format, 
for example to select software decoding for HEVC and hardware decoding 
for other formats

Peter
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mythtv.org/pipermail/mythtv-dev/attachments/20171012/249e0acd/attachment.html>


More information about the mythtv-dev mailing list