[mythtv] mythmusic support broken in DMO mythweb 1:0.27.6-dmo2 (one fixed in git + one remaining issue)

Ian Campbell ijc at hellion.org.uk
Sat Apr 2 11:10:18 UTC 2016

Hi Christian, Karl and Stuart,

With the current mythweb package when visiting mythweb/music I get a
blank page and this in the apache error.log:

[Sat Apr 02 11:27:43.840900 2016] [:error] [pid 2892] [client] PHP Parse error:  syntax error, unexpected ';' in /usr/share/mythtv/mythweb/modules/music/mp3act_functions.php on line 53, referer: http://mythtv/

Which is fixed in the fixes/0.27 branch by:

commit 7cefc58290d5ef2fc02ebf7e0d51b9532f2f8828
Author: Karl Dietz <dekarl at mythtv.org>
Date:   Sun Feb 7 19:12:28 2016 +0100

    fix syntax error after f4240e5e48f25fa40e84faabffa5522b009ab6e0
    pointed out by Piotr Oniszczuk
    Refs #12588
    (cherry picked from commit 93adb4d962a27352fd1cf772d46af59d1b201090)

I cowboyed that patch onto an installed system and it fixed the syntax
error, however when I go to Music -> Browse -> Some letter I just get a
"LOADING..." overlay which never goes away.

0.27.5-dmo1 was the previous packaged version which works for me,
between .5 and .6 is just:

da1e99c Fixes #12588 PHP7 Support. Switch to mysqli plugin
f3931a9 Refs #12588 PHP7 Support. Remove depreciated assignment.

I looked and/tried some the various follow ups in master but nothing

I'm running on Debian with php5 (5.6.19+dfsg-2). I tried switching from
php5-mysql to php5-mysqlnd (no I idea what the difference is), but that
didn't help.

I also tried installing php7.0 php7.0-mysql libapache2-mod-php7.0 and
"a2dismod php5 ; a2enmod php7.0 ; service apache2 reload" but no change
there either.



More information about the mythtv-dev mailing list