[mythtv] Fix for Firewire Recording Endless Errors Warning: No Input in xxx msec

Steven Adeff adeffs.mythtv at gmail.com
Tue Feb 7 16:56:55 UTC 2012

On Tue, Feb 7, 2012 at 10:23 AM, Derek Atkins <warlord at mit.edu> wrote:
> Daniel Kristjansson <danielk at cuymedia.net> writes:
>> The bus reset allows you to record from Motorola equipment after you
>> have tuned to an encrypted channel or when the box just gets wedged.
>> However the bus reset only works if there is one and only one STB
>> connected to your firewire bus. Bus resets are done whenever someone
> I think I was being bit by this latter issue; I had two boxes connected
> and a bus reset would kill a working recording.
>> plugs a new firewire device onto the chain (or removes a device) in
>> OSX, so equipment shouldn't really have a huge problem with resets.

before purchasing a Ceton I had been running two boxes on one machine
and had to disable the firewire reset. eventually I just bought a
firewire card for our main frontend and moved one of the boxes to it
so I could enable the firewire reset on both backends which made
things work much better. while I did have both connected I had written
a channel change script that attempted to use firewire_tester to try
and get it to "work" before handing back to mythbackend for actual
recording, this helped about 95% of the time when it was not working
after initial channel change.

the Ceton just works though, always, plus no cable box fees (~$35/mo)
and two extra tuners... so we no longer have any cable boxen in the

Before you ask, read the FAQ!
then search the Wiki, and this list,
Mailinglist etiquette -

More information about the mythtv-dev mailing list