[mythtv] mythfrontend crashing out from mythweather in recent builds

Matt W mwood23 at gmail.com
Sat Mar 26 15:51:33 UTC 2011

Hi all--

I've noticed in recent git builds, mythweather's background scripts will
crash out mythfrontend with a fair amount of regularity.  Unfortunately
there's not really any useful debug info in the mythfrontend log:

2011-03-26 03:39:02.879 Starting update of NDFD-18_Hour
2011-03-26 03:54:02.956 Starting update of NDFD-18_Hour
2011-03-26 04:09:01.828 Starting update of NWS-XML
2011-03-26 04:09:03.036 Starting update of NDFD-18_Hour
2011-03-26 04:24:03.253 Starting update of NDFD-18_Hour
[ mythfrontend died here ]

i have one line in /var/log/messages..

Mar 26 04:24:07 mythtv2 kernel: [7676004.028267] mythfrontend[14965]:
segfault at 0 ip 670070 sp 43965d78 error 6 in mythfrontend[400000+298000]

seems to have been happening with recent builds, and this one occurred with

mythtv at mythtv2:~$ mythfrontend  --version
Please attach all output as a file in bug reports.
MythTV Version   : v0.25pre-1533-g454f853
MythTV Branch    : master
Network Protocol : 65
Library API      : 0.25.20110324-1
QT Version       : 4.6.3
Options compiled in:
 linux release use_hidesyms using_alsa using_backend using_bindings_php
using_dvb using_frontend using_lirc using_mheg using_opengl_video
using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_php
using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_mheg

Is there an extra logging switch or maybe some debug switches I could set in
the mythweather perl scripts, that might give some more info?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.mythtv.org/pipermail/mythtv-dev/attachments/20110326/9f9eaeab/attachment.html 

More information about the mythtv-dev mailing list