[mythtv] Fwd: Re: [mythtv-commits] Ticket #9400: MacOS X Compile failure

Craig Treleaven ctreleaven at cogeco.ca
Tue Jan 4 12:57:11 UTC 2011

At 5:18 PM +1100 1/4/11, Nigel Pearson wrote:
>On 04/01/2011, at 5:01 PM, Gavin Hurlbut wrote:
>> On Mon, Jan 3, 2011 at 9:59 PM, Nigel Pearson <nigel at ind.tansu.com.au> wrote:
>>> For now, occasionally download a fresh one from:
>>> https://github.com/MythTV/packaging/raw/Use-Git/OSX/build/osx-packager.pl
>> Also, nothing stopping Craig and others from just cloning the
>> packaging repo and then doing
> > "git checkout Use-Git". :)
>Indeed, though that assumes you have Git on the machine
>(the script downloads and builds it if you don't)

Thanks guys. 

BTW, I've had some success!  Starting from Nigel's osx-packager.pl script, the 0.24-fixes frontend, backend, and job queue all built (including several plugins) on OS X 10.5.8. 

mythwelcome, however, was missing which prevented MythWelcome.app from being built.  (I fudged the script to skip it.)

The Python bindings failed which prevented MythNetbrowser from building.  (I went through this before and suddenly, it just started working.  I'll try again to determine what is holding it back.)  The Python bindings also require several modules that are not present on OS X:  MySQLdb, lxml, pycurl, oauth.

Finally, there are several dependencies for the Perl bindings (Date::Manip, etc) that are not present on Mac OS (at least 10.5.x) as delivered.  I believe administrator privileges are required to install them (eg 'sudo /usr/bin/cpan install Date::Manip').

I've manually installed the missing Python and Perl requirements.  Shouldn't we really have a one-time script that installs this stuff?  I wish I could do it, but I know almost nothing about Perl and even less about Python!  At the least, I'll update the wiki when I've got a more-complete build working.


More information about the mythtv-dev mailing list