[mythtv] hdaudio branch issue?

Tom Lichti redpepperracing at gmail.com
Tue May 18 17:35:07 UTC 2010

On Tue, May 18, 2010 at 1:10 PM, Colin Guthrie <mythtv at colin.guthr.ie> wrote:
> 'Twas brillig, and Tom Lichti at 18/05/10 15:54 did gyre and gimble:
>> I moved to the hdaudio branch yesterday to see how it's going, and for
>> the most part it works well, but I do have an issue, and I'm not sure
>> if it's just my configuration, or a problem with the code. If I set
>> the Audio output device to ALSA:default, Stereo, no advanced config,
>> and Mixer Device to /dev/mixer (or ALSA:default), Mixer Controls: PCM,
>> I get :
>> 2010-05-18 10:41:00.067 ALSA, Error: snd_pcm_info_get_card: Operation
>> not permitted
>> 2010-05-18 10:41:00.088 ALSA, Error: Mixer attach error. Check Mixer
>> Name in Setup: '/dev/mixer'.
>>                 Error: No such file or directory
>> In the log. This is odd, because the device is there:
>> [root at xxx log]# ls -l /dev/mixer
>> crw-rw----+ 1 root mythtv 14, 0 2010-05-07 19:04 /dev/mixer
>> During playback I have no control over the volume within MythTV.
>> Previously with this setup (pre hdaudio) I had full control over the
>> volume, so I can only assume that this is an intentional change.
> FWIW, /dev/mixer is not an ALSA mixer, but an OSS mixer. So for alsa code to
> be using it is a bit strange. You do say above that you tried ALSA:default
> too, so it's kinda strange that an error relating to /dev/mixer would show
> up under these circumstances.
> If a value of ALSA:default for the output itself and /dev/mixer in the mixer
> worked before, it would be due to the fact that ALSA provides OSS emulation
> on your distro and thus changes to levels via OSS were reflected also in
> ALSA. This OSS emulation is gradually being phased out now. Fedora do not
> enable OSS emulation by default any longer for example.
> With this additional information, perhaps you can do some more testing?

I'll see what I can come up with. There was also one combination, I
forget which, that completely disabled audio output completely.

I did manually change the ownership of /dev/mixer from root:root to
root:mythtv, but I don't think that changed anything.


More information about the mythtv-dev mailing list