[mythtv] Ticket #8679: mythfrontend deletes settings when db connection is "weak" (was Re: Please unlock ticket)

Thomas Börkel thomas at boerkel.de
Sun Jul 25 07:35:52 UTC 2010


On 25.07.2010 04:40, Michael T. Dean wrote:

> In other words, the list is the best place to have a discussion and to
> brainstorm on what my be causing the issue you're seeing.  We try to
> keep the bug reports in the bug database as small as possible so that
> the developer reviewing the ticket isn't bogged down in "extra"
> information.  And, developers do use Gossamer Threads to look up on-list
> threads about the ticket, so with an appropriate subject (as we now
> have--see above), any relevant discussion will be noticed.

That's good. Still I don't see why the ticket should be closed as
invalid and locked. It was closed and locked because of a wrong
configuration and I proofed that this is not the case.

> Also, since there's no code at all in MythTV that will ever delete all
> settings for a host, there's likely something else going on (i.e.
> hostname/IP address change or similar) that makes it /seem/ like
> settings are being deleted.  It will be much easier to figure out
> everything that's happening in a discussion, here on the list.

You are right. It did not delete ALL settings. You can see in
http://www.boerkel.de/mythfrontend.log which settings it deleted.

After the incident, at least the displayprofiles were all gone and the
mythgallery path was reset to default.

Other settings (like the theme) where still there. Then I restored the
settings from the backup.


More information about the mythtv-dev mailing list