[mythtv] transcode hangs after finishing with 0.22

Christian Neubauer bauner at gmx.de
Sat Jan 9 23:36:56 UTC 2010

Mythtranscode hang forever when delete files slowly was enabled.
I had this with 0.22 and 0.22 fixes a few weeks ago.

-----Ursprüngliche Nachricht-----
Von: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-bounces at mythtv.org] Im
Auftrag von Michael T. Dean
Gesendet: Samstag, 9. Januar 2010 19:43
An: Development of mythtv
Betreff: Re: [mythtv] transcode hangs after finishing with 0.22

<fixed quoting and top-posting>

On 01/07/2010 01:08 PM, Christian Neubauer wrote:
> Von: Martin Koller
>> On Friday 25 December 2009 14:05:00 Stuart Morgan wrote:
>>> On Thursday 24 Dec 2009 14:52:53 Martin Koller wrote:
>>>> Any developer with an idea what could be wrong ?
>>> It's a known QT bug.
>> Is there a Qt-bugnumber to track this ?
>> (on http://bugreports.qt.nokia.com/secure/Dashboard.jspa )
>> As this effects everybody (I assume), is there a known workaround ?
> Disabling delete files slowly in backend settings fixed it for me

Do you mean that if you leave "Delete files slowly" enabled that transcodes
hang /forever/ or just that transcodes hang for approximately 2min/GiB of
the original file (assuming you have no other deletes in progress in the
delete queue at the time when mythtranscode finishes).

I've run a /lot/ of transcodes (started through mythfrontend, but run on
mythbackend in the job queue) with "Delete files slowly" enabled to try to
reproduce the problem and I have not yet been able to get mythtranscode to
hang after finishing (whether I have it delete the original file or not).

Perhaps you have a "stuck" delete queue due to
http://svn.mythtv.org/trac/ticket/7692 (which /might/ be related--though I
haven't investigates #7692, so I'm just guessing, here).

mythtv-dev mailing list
mythtv-dev at mythtv.org

More information about the mythtv-dev mailing list