[mythtv] Incessant flip/flop of deinterlacer in svn

Dave dave at 0bits.com
Tue Sep 15 11:24:15 UTC 2009

On 09/15/09 10:24, Paul Gardiner  wrote:
 > > Hi devs,
 > >
 > > I know this has been discussed forever but i think more and more
 > > broadcasters are transmitting mixed frames to conserve bandwidth 
 > > to spamming in mythtv logs (ok, so i can turn verbosity down) when the
 > > deinterlacer is turned on and off constantly:
 > >
 > > [snip]
 > >
 > > As there seems to be no fix for this except by manually (not good for
 > > WAF) turning progressive detection off via the menu, i'm happy to 
 > > some sort of temporary bandaid to turn off detection if the rate of
 > > toggling exceeds a certain threshold within a 10s period (or something
 > > like that). This seems to be happening on more and more channels and
 > > becoming somewhat an irritation with jerky motion making me and the
 > > family dizzy.
 > >
 > > Have i missed some post which tells me how to fix this or am i
 > > approaching this the wrong way ? Any comments welcome.
 > Tom Dexter had a patch for this that in particular correctly
 > handled the case of displaying interlaced content to a display
 > in an interlaced configuration. It would be good to account
 > for that mode of use while fixing this. (I can't remember
 > the details now, but I am pretty sure that what he did
 > never made it to trunk.)
 > Cheers,
 >       Paul.

I think you're referring to the fieldorder filter ? This went into trunk 
and compiles/installs but there seems to be no way to enable it via the 
setup screens. I think it is also restricted to what renderers it will 
work with and i don't think works with vdpau ? Some correct me if i'm 
wrong ? I tried it a while ago but it gave me a error in the logs about 
not working with vdpau.


More information about the mythtv-dev mailing list