[mythtv] Problems importing channels.conf

Benny Renkens benny.renkens at gmail.com
Tue Sep 15 08:47:55 UTC 2009

That's right: mythtvbackend is not running when I'm doing this.

The message: "Failed to open %1" sounds to me like te variable of the
filename not being passed through properly to the module which does
the actual importing of the channels.conf file. Where shall I start
searching in the code?

----- Original Message -----

Did you make sure that mythbackend was not running before running

----- Original Message -----
On 9/14/09, Benny Renkens <benny.renkens at gmail.com> wrote:
> Hello,
>  Since a couple of days I checked out a new revision of mythtv
>  (revision 21779). After some small problem during compilation (missing
>  define in util-vdpau.cpp) Everything seemed to go smoothly. I'm using
>  a Technotrend S2 3200 card, and mythtv seems to recognize it without
>  any patching. Great.
>  Everything went ok untill I tried to import my channels.conf file.
>  Starting "mythtv-setup -v all" didn't really provide more usefull
>  information I just get the error "Failed to open %1" when I click
>  "next" in the "input connections" screen. (Just after specifying the
>  location of my channels.conf.) I tried all the obvious stuff:
>  * Fill in complete pathname including file / excluding file,
>  * Starting mytht-setup with verbose output,
>  * Threw away entrire database content and re-created empty one.
>  * Doing stuff as root
>  * Tried to find the error in the code base but "Failed to open" is to generic
>  I'm really running out of options, except for inserting the channels
>  manually into the sql database. Which is alot of work I guess...
>  Does anybody have any ideas?
>  Thanx...

More information about the mythtv-dev mailing list