[mythtv] Trunc doesn't compile on gentoo x86

Jean-Yves Avenard jyavenard at gmail.com
Mon Sep 14 10:09:45 UTC 2009

For a start, you're writing to the wrong distribution list. This is
about mythtv development. Nothing to do on how to compile and get
mythtv up and running on your machine

2009/9/14 Armel LANGLET <Armel.langlet at koans.fr>:

> I'm on gentoo, so this web page don't help me a lot.

The dependencies are completely unrelated to the linux distribution
you are running.

> What are the prequisites changes beetween release-0-21-fixes and trunk ? The first one just compile fine but not the second. I know the QT4 dependencies for the trunk version, but what else ?

According to the configure output you posted, I doubt even 0.21-fixes
would compile . You're missing development libraries for almost all
components : sounds, videos. opengl

For trunk things depends on Qt3 rather than Qt4. You also need the
nvidia development libraries to compile with VDPAU support

> And I'm not sure this is a problem of missing headers. The errors are relatives to MMX et regiters stuffs.

It definitely is... without the proper headers, how do you want things
to be defined and compile properly?

More information about the mythtv-dev mailing list