[mythtv] Mac OS X build status

George Nassas gnassas at mac.com
Mon Jul 27 17:26:45 UTC 2009

On 26-Jul-09, at 7:24 PM, Nigel Pearson wrote:
> On 11/07/2009, at 3:53 AM, George Nassas wrote:
>> On Intel / 10.5 / Xcode 3.1 I got that "out of registers" error  
>> until I applied the #19322 change to mythtv/filters/yadif/ 
>> yadif.pro. Now it gets all the way to mythvideo but I don't have  
>> time to figure out what is wrong there.
> I haven't been able to reproduce that problem,
> so when (if?) you do get time, could you maybe provide:

I just tried again with a fresh full run (ie, osx-packager in an empty  
directory) and I now get a different problem about a bunch of  
undefined symbols when it tries to build libmythui.

> 1) libs/libmythdb/mythconfig.mak
> and libs/libmythdb/mythconfig.h


for the original failure and:


for the new one.

> 2) gcc -v

Using built-in specs.
Target: i686-apple-darwin9
Configured with: /var/tmp/gcc/gcc-5493~1/src/configure --disable- 
checking -enable-werror --prefix=/usr --mandir=/share/man --enable- 
languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/ 
$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/ 
lib --build=i686-apple-darwin9 --with-arch=apple --with-tune=generic -- 
host=i686-apple-darwin9 --target=i686-apple-darwin9
Thread model: posix
gcc version 4.0.1 (Apple Inc. build 5493)

I have a bunch of macports stuff installed but I can't say if that's a  

> 3) a full build trace?


I ran these with:

(./osx-packager.pl \
     -debug \
     -verbose \
     -enable-backend \
  2>&1) | tee -a osx.log

except, of course, to rerun the older one I added -nohead to use the  
source I had back with that original problem.

- George

More information about the mythtv-dev mailing list