[mythtv] [mythtv-commits] Ticket #6725: segmentation fault in mythbackend

Nick Morrott knowledgejunkie at gmail.com
Thu Jul 16 20:24:05 UTC 2009

On 16/07/2009, Simon Kenyon <simon at koala.ie> wrote:
> Nick Morrott wrote:

> > Echoing Mike Dean's frequent suggestion, I would do a "Delete all
> > capture cards" and then just configure the card you are using for
> > testing. Your log indicated you are using the DVB-S card that uses the
> > "ST STV0299 DVB-S" frontend (DVB adapter 1).
> >
> >
>  but as you know yourself, deleting all capture cards and adding them again
> is a bit drastic
>  this is a production system - i'm not using it for "testing" - i'm using it
> for "watching" :-)

Deleting capture cards is no problem at all, and I've done a delete
and restore on my production sytem in a couple of minutes in my 4 card
setup. I think you mean deleting your video sources - that is where
the channels are defined and channel numbering updated, and wherein
the pain lies. Your issues may however be unrelated to your capture
card/video source configuration.

I do not appear to have problems with channels moving around on DVB-S
either - do you see these on Freesat channels or other FTA channels? I
did a full reinstall last week after a couple of years and when I did
so, started to hack up some scripts for Freesat xmltv and channel
renumbering (by serviceid currently). I'll post them when I've
finished them as you'll likely find them very helpful. Freesat channel
numbering during the channel scan is in the pipeline, so that will be
very welcome when it arrives.


Nick Morrott

MythTV Official wiki:
MythTV users list archive:

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-dev mailing list