[mythtv] Ticket #6036: Xlib: unexpected async reply (sequence 0x2b)!

Eric Bosch eric.bosch at comcast.net
Thu Jan 1 20:35:13 UTC 2009

I have observed in improvement on this issue, however, if I try to start 
picture-in-picture, picture-by-picture, it is still highly susceptible to 
this lock.  Additionally, from the view-recordings screen with preview 
generation enabled, this lock still happens periodically.
----- Original Message ----- 
From: "MythTV" <mythtv at cvs.mythtv.org>
To: <mythtv-commits at mythtv.org>
Sent: Wednesday, December 31, 2008 2:37 PM
Subject: Re: Ticket #6036: Xlib: unexpected async reply (sequence 0x2b)!

> #6036: Xlib: unexpected async reply (sequence 0x2b)!
> ------------------------------------------------+---------------------------
> Reporter:  Ben Dailey <ben at inspiredtechs.com>  |        Owner:  danielk
>     Type:  defect                              |       Status:  assigned
> Priority:  major                               |    Milestone:  0.22
> Component:  mythtv                              |      Version:  head
> Severity:  medium                              |   Resolution:
>  Mlocked:  0                                   |
> ------------------------------------------------+---------------------------
> Comment(by Ben Dailey <ben at inspiredtechs.com>):
> OK after much more testing and trying to come up with a reliable way to
> reproduce the problem I think I may have some hints or at least
> observations. I can confirm for with absolute certainty that the problem
> occurs with and with out opengl vsync turned on at run time. I was able to
> come up with backtraces for opengl vsync on and off. I have attached the
> logs and backtraces (Actual files no copy and paste). OK observations: No
> reliable way to reproduce, but I would startx, then launch gdb and run
> mythtfrontend. As soon as the frontend started I would connect via telnet
> and issue "jump livetv".
> Every time I got the "Xlib: unexpected async reply (sequence 0x2b)!" error
> message and the frontend would hang the following message was always
> missing from the log output: "VDP: LoadBestPreferences(1920x1088, 29.97)"
> Please include all output in bug reports.[[BR]]
> MythTV Version   : 19512[[BR]]
> MythTV Branch    : trunk[[BR]]
> Library API      : 0.22.20081222-1[[BR]]
> Network Protocol : 43[[BR]]
> QT Version       : 4.4.2[[BR]]
> Options compiled in:[[BR]]
>  linux debug using_alsa using_backend using_dvb using_frontend using_mheg
> using_opengl_video using_opengl_vsync using_qtwebkit using_x11
> using_xrandr using_xv using_xvmc using_xvmc_opengl using_bindings_perl
> using_bindings_python using_opengl using_ffmpeg_threads using_mheg
> using_xvmc_pbuffer
> -- 
> Ticket URL: <http://svn.mythtv.org/trac/ticket/6036#comment:7>
> MythTV <http://www.mythtv.org/>
> MythTV

More information about the mythtv-dev mailing list