[mythtv] osx-packager.pl wont build trunk

David Snider dsnider at thesniderpad.com
Sat Apr 11 13:54:11 UTC 2009

  ----- Original Message ----- 
  From: Alain Ramos 
  To: Development of mythtv 
  Sent: Friday, April 10, 2009 9:21 PM
  Subject: Re: [mythtv] osx-packager.pl wont build trunk

  It's band new.

  On Fri, Apr 10, 2009 at 11:18 PM, David Snider <dsnider at thesniderpad.com> wrote:

    On Apr 10, 2009, at 6:50 PM, Alain Ramos wrote:

      Hey all I put this message up in the users list but realized it would make more sense in the dev list. My problem is that osx-packager.pl wont build for ppc os 10.5.6 from the latest trunk I get this...

      [osx-pkg] /Users/julie/.osx-packager/src/myth-svn/packaging//packaging.pro does not exist. You must be building really old source?
      ls: /Developer/FireWireSDK*/Examples/Framework/AVCVideoServices.framework: No such file or directory
      cp: /Users/julie/MythFrontend.app/Contents/Frameworks//Library/Frameworks/Jackmp.framework/Versions/A/Jackmp.framework/Versions/A//Library/Frameworks/Jackmp.framework/Versions/A/Jackmp: No such file or directory
      osx-bundler: Failed system call: " /bin/cp /Library/Frameworks/Jackmp.framework/Versions/A/Jackmp /Users/julie/MythFrontend.app/Contents/Frameworks//Library/Frameworks/Jackmp.framework/Versions/A/Jackmp.framework/Versions/A//Library/Frameworks/Jackmp.framework/Versions/A/Jackmp " with error code 1
      Died at /Users/julie/.osx-packager/src/myth-svn/packaging/OSX/build/osx-bundler.pl line 196.
      [osx-pkg] Failed system call: " /Users/julie/.osx-packager/src/myth-svn/packaging/OSX/build/osx-bundler.pl /Users/julie/MythFrontend /Users/julie/.osx-packager/build/lib/ /Users/julie/.osx-packager/build/lib/mysql " with error code 2
      Died at /Users/julie/.osx-packager/src/myth-svn/packaging/OSX/build/osx-packager.pl line 990.

      But I have that file in my frameworks under /Library/Frameworks/Jackmp.framework/Versions/A/Jackmp. I dont know what the deal is but can someone help? It seems as though there is some funkiness with directories in  osx-bundler but I don't really know how to fix the problem. I got revision 20345 and I am compiling on ppc os 10.5.6.


    Is this a brand new compile, or have you been compiling from this same directory for a while?

    OK, are you using the same osx-packager.pl from revision 20345?  Or a previously downloaded version?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-dev/attachments/20090411/ff61be73/attachment.htm>

More information about the mythtv-dev mailing list