[mythtv] SA4250 firewire channel change suddenly stopped working

Scott Bickford bic1ster at gmail.com
Wed Oct 29 14:33:20 UTC 2008

As of yesterday morning or so, my firewire sa4250_ch stopped working (was
working last six months).  I unplugged power from the SA4250 and let it sit
about 15 seconds.  I shutdown MythTV.  I also tried the other FW port on the
STB.  Usually when the channel change request is done, I can see it on the
LCD of the STB, this does not happen.  I tried the test-mpeg2 -r 1 >
test.mpg, which actually works, all though playback is not smooth.  So FW is
working to some extent, but not channel change.  Priming in the past has
done pretty much nothing and just fails like nuts, so I did not even try it.

./sa4250_ch 2 -v
node 0: vendor_id = 0x000090a9 model_id = 0x00000000
node 1: vendor_id = 0x00001ac3 model_id = 0x000010cc
Device acquired on node 1
Changing channel 2
AV/C Command: cmd0=0x00487ce7 cmd1=0x04000200 cmd2=0xff000000

I am on MythDora 5.  For the sa4250_ch I had to add in the SA4250 vendor and
model ids.

I see on the STB info screens a lot of firmware had dates of August 2008.
It sounds like something has changed on the STB where it is not recognizing
the channel change request.

Host Adapter 0

Node 0 GUID 0x0090a94008005308
libiec61883 error: error reading oMPR
libiec61883 error: error reading iMPR

Node 1 GUID 0x001ac3f83c5c0000
oMPR n_plugs=1, data_rate=2, bcast_channel=63
oPCR[0] online=1, bcast_connection=0, n_p2p_connections=1
        channel=0, data_rate=2, overhead_id=0, payload=146
iMPR n_plugs=0, data_rate=2

Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20081029/3afef436/attachment.htm 

More information about the mythtv-dev mailing list