[mythtv] Firewire Motorola 6200 in 0.21 w. firewire_ohci

Joe Julian joe at julianfamily.org
Tue Oct 7 12:49:06 UTC 2008

I can't get my 6200 to record at all in 0.21 using the stock 
firewire_ohci in 2.6.26. The problem comes from here:

LFireDev(001AADFFFE129A49), Error: Starting A/V streaming
eno: Device or resource busy (16)

Which happens when we call iec61883_mpeg2_recv_start for the second 
time. The first time it opens fine, and closes right away. Not sure what 
we're doing that time, but the second time it errors with errno=16. This 
error actually comes when iec61883_mpeg2_recv_start calls 

I modified test_mpeg2.c to try the same method. I created the handle 
(raw1394_new_handle_on_port), iec61883_cmp_connect, raw1394_loop_iterate 
to receive a bunch of mpeg-ts, iec61883_mpeg2_close then tried looping 
back to iec61883_cmp_connect, which is what linuxfirewiredevice.cpp 
does. I get the same error 16.

If I raw1394_destroy_handle at the end of the loop, then 
raw1394_new_handle_on_port at the beginning, I can stream all day long ( 
2 Tb long anyway... ).

Since raw1394_new_handle_on_port is in LinuxAVCInfo, I wasn't sure what 
to try changing to see if I can duplicate the results in MythTV.

More information about the mythtv-dev mailing list