[mythtv] Mythtv and kernel 2.6.25

Paulo Cavalcanti promac at gmail.com
Sun Jun 22 13:48:19 UTC 2008

On Sun, Jun 22, 2008 at 6:56 AM, Andrew M. Bishop <amb at gedanken.demon.co.uk>

> "Paulo Cavalcanti" <promac at gmail.com> writes:
> >> > I am having problems to make mythtv work with kernel 2.6.25 (Fedora
> 8).
> >> >
> >> > The problem seems to be my capture card, a Prolink Pixelview.
> >> ...
> >>
> >> Sounds like a problem with the driver for your capture card.
> >> Try taking this to http://www.linuxtv.org/lists.php
> >>
> >> My guess is other programs like xawtv will also be broken with the newer
> >> kernel...
> > No. xawtv and tvtime play just fine. The system is also pretty stable.
> >
> > The only problem is mythtv (LiveTV). The version of the bttv driver is
> the
> > same (0.9.17) on both kernels.
> >
> > That is why I am asking a direction here. I see no way of isolating the
> > problem, without knowing how myth interacts with the hardware.
> I had the same problem and stayed on kernel 2.6.24 with my bttv cards.
> I did some investigation and the problem seems to be related to the
> changeover to V4L2 in 2.6.25.
> This message http://lkml.org/lkml/2008/1/6/83 describes a patch to the
> bttv driver, but if you look at the 2.6.25 kernel source you will see
> that it isn't there.  If you apply this patch (like I tried) then it
> will get further, it won't lockup but I didn't get any video either.
> I e-mailed video4linux-list at redhat.com, v4l-dvb-maintainer at linuxtv.org
> and mchehab at infradead.org reporting the problem, but the e-mail never
> appeared on the list and I had no reply from the maintainer.
> There looks like there is a different patch for this problem in the
> latest v4l git tree and mainline kernel, but I haven't tried them:
> http://git.kernel.org/?p=linux/kernel/git/mchehab/v4l-dvb.git;a=commitdiff;h=81b2dbcad86732ffc02bad87aa25c4651199fc77
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=81b2dbcad86732ffc02bad87aa25c4651199fc77
> I am waiting for kernel 2.6.26 and hoping that it will work again.

I rebuilt video4linux from ATrpms using today's snapshot,
and it worked.

Well, almost. If I try mythtv Live TV after rebooting, I get a green screen
(but no lock).
However, If I run mplayer before using mythtv, Live TV works just fine.
Maybe this is related to the nvidia driver I am using. I did not try the
latest one (173.14.09).

I will ask Axel to make video4linux (20080622) available to the public.

Thanks for the clue.

Paulo Roma Cavalcanti
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20080622/f163299f/attachment.htm 

More information about the mythtv-dev mailing list