[mythtv] Resurrecting MythBrowser after the switch to Qt4

Janne Grunau janne-mythtv at grunau.be
Thu Jul 17 11:18:16 UTC 2008

On Thursday 17 July 2008 12:34:43 Paul Harrison wrote:
> I'm going to start looking at resurrecting MythBrowser and now that
> WebKit is part of Qt4.4 thats the approach I was going to take.
> Would there be any objections to making Qt4.4 the minimum version
> required for trunk?

I think it's quite early in the life of Qt 4.4 and we have been 
conversative with required software. The situation will be better in 
six months (when all distros are updated with KDE 4.2).

> If there is no problem with that then I'd create a generic mythuitype
> based on QWebPage that can be used on any  screen. That would be the
> most useful in the long run but requires the most work and would
> require Qt4.4 as the minimum.
> The other alternative would be to just require Qt 4.4 for the
> MythBrowser plugin and use QWebView. That would be by far the easiest
> approach but would be the least flexible.

Without knowing MythUI or QtWebKit in detail is it not possible to use 
the first approach but have the class for now in mythbrowser/mythui and 
move it mythui when we are comfortable to require Qt 4.4?


More information about the mythtv-dev mailing list