[mythtv] Resurrecting MythBrowser after the switch to Qt4

Paul Harrison mythtv at dsl.pipex.com
Thu Jul 17 10:34:43 UTC 2008

I'm going to start looking at resurrecting MythBrowser and now that 
WebKit is part of Qt4.4 thats the approach I was going to take.

Would there be any objections to making Qt4.4 the minimum version 
required for trunk?

If there is no problem with that then I'd create a generic mythuitype 
based on QWebPage that can be used on any  screen. That would be the 
most useful in the long run but requires the most work and would require 
Qt4.4 as the minimum.

The other alternative would be to just require Qt 4.4 for the 
MythBrowser plugin and use QWebView. That would be by far the easiest 
approach but would be the least flexible.


Paul H.


More information about the mythtv-dev mailing list