[mythtv] Ticket #4497: Win32 builds broken after r15435

Jay Modi jmodi at vt.edu
Mon Jan 21 04:06:56 UTC 2008

On Jan 19, 2008 9:32 PM, MythTV <mythtv at cvs.mythtv.org> wrote:

> #4497: Win32 builds broken after r15435
> ------------------------------------------+---------------------------------
>  Reporter:  Jay Modi <jaymode at gmail.com>  |       Owner:  ijr
>     Type:  patch                         |      Status:  new
>  Priority:  minor                         |   Milestone:  unknown
> Component:  mythtv                        |     Version:  unknown
>  Severity:  medium                        |     Mlocked:  0
> ------------------------------------------+---------------------------------
>  The Win32 builds seem to have been partially broken by r15435. The first
>  issue I noticed is that the typedef on line 89 needs a semicolon.
> However,
>  this leads to even more problems, dealing with multiple definitions. The
>  cure for this is to remove the typedef and then include compat.h but this
>  causes linking errors. These linking errors are due to some other issue,
>  as I have removed the entire r15435 changes from my compat.h and get the
>  same errors.
>  I have attached a patch file to add the include.
> --
> Ticket URL: <http://svn.mythtv.org/trac/ticket/4497>
> MythTV <http://svn.mythtv.org/trac>
> MythTV

I wrote this ticket up last night and have tried again today with a clean
subversion checkout and no patches applied. Now the weird thing is that I
got a new error today. This error comes in a file that has not been changed
in years according to trac. Is anyone else (the few of us) that are building
with MinGW experiencing similar issues on the HEAD revision of svn.

Using this configure command:
./configure --prefix=/usr --disable-dbox2 --disable-hdhomerun --disable-dvb
-disable-ivtv --disable-iptv --disable-joystick-menu --disable-xvmc-vld
le-x11 --disable-xvmc --enable-directx --enable-memalign-hack

When I run make, this is the new error:
gcc -c -march=i586 -g -Wall -Wno-switch -Wdisabled-optimization
-Wpointer-arith -Wredundant-decls -fPIC -DPIC -mthreads -w -fexceptions
-DQT_THREAD_SUPPORT -I"/usr/include" -I".." -I"../.." -I"/qt-3.3.x-p8/include"
-I"C:/msys/1.0/qt-3.3.x-p8/mkspecs/win32-g++" -o samplerate.o samplerate.c
In file included from samplerate.c:27:
float_cast.h: In function `lrint':
float_cast.h:90: error: `_asm' undeclared (first use in this function)
float_cast.h:90: error: (Each undeclared identifier is reported only once
float_cast.h:90: error: for each function it appears in.)
float_cast.h:90: error: syntax error before '{' token
float_cast.h: In function `lrintf':
float_cast.h:102: error: `_asm' undeclared (first use in this function)
float_cast.h:102: error: syntax error before '{' token
make[2]: *** [samplerate.o] Error 1
make[2]: Leaving directory `/c/mythtv/mythtv/libs/libmythsamplerate'
make[1]: *** [sub-libmythsamplerate] Error 2
make[1]: Leaving directory `/c/mythtv/mythtv/libs'
make: *** [sub-libs] Error 2
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20080120/49cc25f6/attachment.htm 

More information about the mythtv-dev mailing list