[mythtv] Tuners Unavailable

Mache Creeger mache at creeger.com
Thu Feb 28 19:36:41 UTC 2008

Pardon me for cross posting over from mythtv-users. My family has 
become addicted to myth and without it they are starting to look at 
me strangely.

After having a similar problem of Tuner Unavailable for both PVR 500 
tuners on my MBE, I deleted the Video4linux drivers and the Tuners 
became available, Taking the advice of having all my machines running 
on the same mythtv rev I then updated everything to 0.20.2-175 from 
173 and the Tuners became unavailable again. While I have an SBE and 
am working on adding an FE, both are shut down at this time as I want 
to focus on getting the MBE working again.  I am running Fedora 7,

I have deleted the video sources and the capture cards using 
mythtv-setup on the MBE, rebooted, and reinstalled the capture cards, 
video sources, and inputs. This is exactly the problem I had before 
but now I do not have video4linux to delete to resolve the problem.

I then went back to mythtv-setup, and re-deleted the capture cards 
and video sources and then yum erased ivtv-firmware and ivtv-kmdl. 
After rebooting, I reinstalled ivtv-firmware and ivtv-kmdl, rebooted, 
and then with mythtv-setup re-configured the WinTV PVR 500, the video 
sources, and the inputs. Still no change in Tuner availability.

The WinTV PVR 500 loads fine in dmesg with no errors, but when 
mythbackend goes to initialize the recorder it comes back with none 
found. Turning on --verbose all, does not yield any enlightening information.

Can someone tell what type of logging I can turn on the resolve this 
problem?  It seems that even though the ivtv drivers are working 
fine, something is broken when mythbackend tries to work with it.

-- Mache

Additional information:

I did the following tests:

# cat /dev/video0 > test0.mpg
# cat /dev/video1 > test1.mpg

and both had good video as played by mplayer.

-- Mache

Here are some log excerpts from /var/log/mythtv/mythbackend

2008-02-27 22:40:47.945 mythbackend version: 0.20.20070821-1 www.mythtv.org
2008-02-27 22:40:47.945 Enabled verbose msgs: all
2008-02-27 22:40:47.946 AutoExpire: Found 0 recorders w/max rate of 0 MiB/min

2008-02-27 22:40:48.615 Encoder card 1 free space -1
2008-02-27 22:40:48.616 Encoder card 2 free space -1

# dmesg | grep ivtv
ivtv:  Start initialization, version 1.0.0
ivtv0: Initializing card #0
ivtv0: Autodetected Hauppauge card (cx23416 based)
ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
ivtv0: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
ivtv0: Encoder revision: 0x02060039
ivtv0: Autodetected WinTV PVR 500 (unit #1)
tuner 2-0043: chip found @ 0x86 (ivtv i2c driver #0)
tuner 2-0060: chip found @ 0xc0 (ivtv i2c driver #0)
tuner 2-0061: chip found @ 0xc2 (ivtv i2c driver #0)
cx25840 2-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #0)
wm8775 2-001b: chip found @ 0x36 (ivtv i2c driver #0)
ivtv0: Registered device video0 for encoder MPEG (4 MB)
ivtv0: Registered device video32 for encoder YUV (2 MB)
ivtv0: Registered device vbi0 for encoder VBI (1 MB)
ivtv0: Registered device video24 for encoder PCM audio (1 MB)
ivtv0: Registered device radio0 for encoder radio
ivtv0: Initialized card #0: WinTV PVR 500 (unit #1)
ivtv1: Initializing card #1
ivtv1: Autodetected Hauppauge card (cx23416 based)
ivtv1: Unreasonably low latency timer, setting to 64 (was 32)
ivtv1: Loaded v4l-cx2341x-enc.fw firmware (376836 bytes)
ivtv1: Encoder revision: 0x02060039
tuner 3-0043: chip found @ 0x86 (ivtv i2c driver #1)
tuner 3-0061: chip found @ 0xc2 (ivtv i2c driver #1)
cx25840 3-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #1)
wm8775 3-001b: chip found @ 0x36 (ivtv i2c driver #1)
ivtv1: Correcting tveeprom data: no radio present on second unit
ivtv1: Autodetected WinTV PVR 500 (unit #2)
ivtv1: Registered device video1 for encoder MPEG (4 MB)
ivtv1: Registered device video33 for encoder YUV (2 MB)
ivtv1: Registered device vbi1 for encoder VBI (1 MB)
ivtv1: Registered device video25 for encoder PCM audio (1 MB)
ivtv1: Initialized card #1: WinTV PVR 500 (unit #2)
ivtv:  End initialization 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20080228/69e0783b/attachment.htm 

More information about the mythtv-dev mailing list