[mythtv] Memory leaks in 0.20.2-0ubuntu10.1

Neeraj Gupta ngupta44 at gmail.com
Wed Feb 13 00:54:26 UTC 2008

Ok thanks. Let me do some more work on my end.
As mythtv is being used by a huge community and if there are not too many
memory leak reports, then it could be my bad case.
I think it could be the tuner device driver causing leaks.
I will remove the hardware and then just run client-server using
pre-recorded HD programs. This will isolate the problem on mythtv, if any.
So, let me just run home now and watch the "Tonight Show by Jay Leno" for an
hour :) :)
Will post the results.

By the way.. is there any valgrind type tool for device drivers ????


On Feb 12, 2008 2:54 AM, Tino Keitel <tino.keitel at gmx.de> wrote:

> On Tue, Feb 12, 2008 at 00:40:04 -0800, Neeraj Gupta wrote:
> > I started using the mythtv recently and noticed severe memory leak
> symptoms.
> > The system is x86 Ubuntu 7.10 Gutsy upto date on 2/10/2008. Mythtv
> version
> > is 0.20.2.
> > I have 2GB RAM. When system boots up, I run several apps and close them
> > after some time (for testing) and memory usage is normal... even goes
> down
> > when I close all apps. Seen in top, saider, vmstat etc.
> > But when I start using mythtvfrontend on a network client, the memory
> > utilization starts going up and hits 95%. Even after stopping frontend
> and
> > backend, it never recovers. System swap usage also starts.
> To prove that MythTV is the culprit, you should
> 1. post the output of free -m before you start the fronted
> 2. post the output of free -m after you feel to hit the memory leak
> 3. post the output of ps aux when this happens
> Regards,
> Tino
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20080212/e3d266ad/attachment.htm 

More information about the mythtv-dev mailing list