[mythtv] [mythtv-commits] mythtv commit: r15853 by bjm

Bruce Markey bjm at lvcm.com
Fri Feb 8 21:51:47 UTC 2008

Janne Grunau wrote:
> On Friday 08 February 2008 20:34:32 mythtv at cvs.mythtv.org wrote:
>>        Author: bjm
>>          Date: 2008-02-08 19:34:32 +0000 (Fri, 08 Feb 2008)
>> New Revision: 15853
>>     Changeset: http://cvs.mythtv.org/trac/changeset/15853
>> Modified:
>>     trunk/mythtv/programs/mythbackend/scheduler.cpp
>> Log:
>> Revert [15852] .
> why?
> I don't consider programs with 576 or less lines as HDTV even if they
> are widescreen or encoded in MPEG4 AVC.

Then they don't belong in the program.hdtv column.

program.hdtv has been, and actively still is, a bool to indicate
that TMS marked the program as HDTV. This ought to be true or
false. However it is possible that this may have other states
for HDTV programs in the future.

If this is non-zero, the PI bit field should then have its
VID_HDTV bit set to indicate that the theme should show the
HD icon or whatever. It is only by coincidence that enum
VideoProps currently happens to have VID_HDTV = 0x01 as it
appears that this was the first thing added in this enum. It
is only happenstance that the program.hdtv bool can be converted
to the integer for one and the VID_HDTV bit mask in this case
happens to be one when converted to an int.


         curr_schedule.hdtv = (pxmlatts.value("hdtv") == "true");

David Shay's DataDirect code does not set this column based on
the emun value from programinfo.h nor should it have to this

It appears that eit.cpp somehow decided that "videoProps"
should be dumped somewhere and "hdtv", it seems, sounded
like it must be close 'nuff:

     query.bindValue(":HDTV",        videoProps);

If there needs to be a column to hold a set of bit flags that
indicate something other than the program is or isn't HDTV then
there should a different column added for that purpose. However,
to be consistent, there should be columns added for each property
other than the existing stereo, cc, hdtv, etc. Reusing an existing
column (that's currently in use) for a different purpose is really
bad form.

So the underlying question I have from looking at the current
VideoProps is; are VID_WIDESCREEN and/or VID_AVC indications
that the program should be treated as an HDTV broadcast? If the
answer is 'no' then these do not belong in this column. If the
answer is 'yes' then this is what I'd anticipated and the correct
logic is "program.hdtv > 0".

> Reverting commits without giving a reason is not nice, even if they are
> buggy.

Nor is reapplying the same code without asking for, or even
waiting for, a clarification.

> [15852] fixes a bug in the scheduler since without it gives the HDTV
> priority boost to non HDTV programs.

That's not my bug. A column named 'hdtv" ought to be unambiguous
and you yourself state that this is being populated with info
that does not indicate the program should be considered to be
an HDTV broadcast.

One other point before other changes are considered. I have no
interest in introducing having to parse enums in power search
rules. If you have a grabber that flags widescreen and avc then
columns should be added for program.widescreen and program.avc .

--  bjm

More information about the mythtv-dev mailing list