[mythtv] Ticket #2464: Compile error when compiling with XvMC & g++ 3.3.6

Chris Pinkham cpinkham at bc2va.org
Tue Feb 5 19:36:14 UTC 2008

* On Tue Feb 05, 2008 at 11:37:45AM -0500, Mark Buechler wrote:
> On 2/5/08, MythTV <mythtv at cvs.mythtv.org> wrote:
> >
> > #2464: Compile error when compiling with XvMC & g++ 3.3.6

> Wow, that's and old one..

Nah...  Here's my main dev box:

P</home/cpinkham> cat /etc/redhat-release ; g++ --version | grep GCC ; rpm -qa | egrep "qt-3|qt-MySQL-3"
Red Hat Linux release 9 (Shrike)
g++ (GCC) 3.2.2 20030222 (Red Hat Linux 3.2.2-5)

Other parts of my system aren't near that old, my /usr/local is huge.
I do have 2 fixes in my local tree to allow compiling with such an
old gcc version, but they are total hacks and not svn-worthy.

Been contemplating upgrading recently, but my main root and spare root
partitions aren't big enough so I'll have to repartition my drive which I'm
not looking forward to.


More information about the mythtv-dev mailing list