[mythtv] [mythtv-commits] Ticket #1104: multi channel audio support

Daniel Kristjansson danielk at cuymedia.net
Sun Feb 3 17:01:53 UTC 2008

On Sun, 2008-02-03 at 21:51 +1100, Mark Spieth wrote:
> > Ok, so in my testing so far ALSA:analog works great at 2ch and 5.1ch.
> > Kudos.
> thats because I can use it :)
> there is another patch for #chan changes within a stream to stop the hiccup 
> when audio is reinited.
> Im halfway done lavc fft mods with config but for some reason it doesnt 
> work.

There was actually one problem, when playing a stereo recording
with 5.1 up mixing  the front speaker volume was about 6 db too
low in volume when compared to an AC3 recording.

> > I have not tested with other audio output methods yet or to see if DTS
> Only alsa so far.

I'm just testing to make sure there are no regressions in other output
methods. They don't actually have to have 5.1 sound available.

> >Before I do, had you tested SPDIF output?
> no. only through others and they havent complained recently so I only assume 
> its still ok.
> I dont have a spidf setup yet until I get my new frontend done.
> I should get the hardware this coming week on order.
> > If so and you got sound, what kind of CPU usage were you seeing?
> on my combined XP2000+ analog upmixing fftw3 uses about 39% vs 21% for 2ch 
> for same video.
> no figures for passthru.

Ok, so there was something wrong on my machine then. We don't have to
have this in SVN until mid to late February to make the 0.21 release,
so there is still time to fix the remaining issues.

-- Daniel

More information about the mythtv-dev mailing list