[mythtv] Via XVMC problem after mythtv-vid merge

David Shay david at shay.net
Tue Sep 25 16:53:22 UTC 2007

On 9/22/07, Michael T. Dean <mtdean at thirdcontact.com> wrote:
> On 09/22/2007 01:27 AM, David Shay wrote:
> >
> > On 9/21/07, Robert Johnston <anaerin at gmail.com> wrote:
> >>
> >> On 9/21/07, David Shay <david at shay.net> wrote:
> >>>
> >>> I'm using SVN 14510 with a Via EX10000EG. Openchrome drivers.
> >>> All was working fine before this last SVN upgrade (which was
> >>> pre-mythtv-vid merge). I went in and set up a new video profile,
> >>> and to make things simple, created one which just used Via XVMC
> >>> all of the time. This box only watches MPEG2 recordings that are
> >>> 720x480, so this should be fine.
> >>>
> >>> Mythfrontend shows this error:
> >>>
> >>> <datetime> VideoOutputXv: XvMC Adaptor Name: 'XV_SWOV' Unable to
> >>> create XvMC surface
> >>>
> >>> CPU utilization then goes to about 96%.
> >>>
> >>> Anything I did wrong here?  What other debugging info is needed?
> >>
> >> From the looks of it, you don't have Xv or XvMC support in your
> >> kernel/setup (I'm presuming XV_SWOV means something along the lines
> >> of XVideo SoftWare Overlay Video).
> >>
> >> Check that your openchrome drivers are working AOK (Try using
> >> mplayer with -vo XvMC and see if that works before trying to blame
> >> Myth).
> >
> > Not it. As I said, Myth before the mythtv-vid merge was working fine.
> > Xine -V xxmc works just fine too.
> Did you do a make distclean?  I've heard reports of mmx being disabled
> until the user did a make distclean.  (Also, knowing it worked before
> doesn't prove that it was enabled by configure.  Check the configure
> output.)
> Mike

 Well, this is now "solved" in the sense that I don't think it was really a
problem in the first place.  The CPU problem was a red herring.  The error
message that I found when attempting to track down the cause of the CPU
problem (which must have been something other than reverting to software
decoding...) was apparently not a real problem, either, according to
danielk.  Essentially, chalk it up to user error...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20070925/feca80ab/attachment.htm 

More information about the mythtv-dev mailing list