[mythtv] first multirec experience (was Re: [mythtv-commits] Ticket #3326: Implement multiple recordings per transport)

Petr Stehlik pstehlik at sophics.cz
Wed Sep 19 09:11:53 UTC 2007

MythTV wrote:
> Comment(by danielk):
>  (In [14505]) Refs #3326. Merges r14410:14504 from trunk to mythtv-multirec

This merge somehow convinced me to jump from the safe harbour of 0.20.x 
  to the wild water of the multirec branch ;-) Spent most time in 
mythtv-setup and thought I'd share my experience...

First, on one of the new setup pages - the one where you connect video 
sources to cards (IIRC) there are buttons off screen. Actually there are 
two drop downs for defining whether the input is shared (IIRC) and the 
second drop down is already partially off, and then there is a button 
for creating something new (a new group of shared inputs?) and that one 
is completely off the right border. Only its help text suggested that 
there is an invisible button. I tried running the mythtv-setup in 
720x576 up to 1280x1024 but the button was always completely off screen 
(since the font size always scaled up so enlarging the resolution didn't 
help at all). BTW, I am wondering how to scroll the help text since it 
was often unfinished (didn't fit in the help window area).

Then in the channel scanner, it crashed in about 50% of all runs but I 
compiled for Release not Debug so I couldn't provide a meaningful 
backtrace. Sometimes it managed to scan one transport but when I was 
adding another one (since for DVB-S this "complete scan" is far from 
complete and one has to enter the frequencies of the favourite 
transports one by one) it crashed. I didn't mean it much - simple 
re-running the mythtv-setup helped to finish the scan. Will rebuild for 
Debug and try to attach a backtrace to the #3326 (or to another ticket?).

At last I got into the Live TV (I didn't have XMLTV set up yet) and by 
simple pressing the 'R' and returning to Live TV again and again I got 
to a point where it was recording four different channels and still 
allowed me to go to Live TV and watch yet another channel (this is 
single LNB pointing to Astra 3A, connected to a Skystar2 card). Quite 
amazing... Thanks for the great work!


P.S. then I had to restore the working 0.20.x so I didn't test more. 
Perhaps tonight...

More information about the mythtv-dev mailing list