[mythtv] ffmpeg sync

Rudy Zijlstra mythtv at grumpydevil.homelinux.org
Tue Oct 30 08:22:40 UTC 2007

Janne Grunau wrote:
> On Tuesday 30 October 2007 00:06:17 Rudy Zijlstra wrote:
>> one remark: can you test in configure in case --enable-proc-opt is
>> used, that gcc is version 4.2 or above? In all other cases the
>> compile will succeed, but the execution will fail....
> please provide more details, at least the configure output. But I'll 
> check gcc4.2 on gentoo amd64 before committing.
> Janne

No issues during configure time... But when running (this was with gcc 
3.x (that computer is off at the moment), i got a runtime warning that 
ffmpeg needed gcc 4.2 if you compiled with proc-opt. It complained about 
a mis-compilation, stated 4.2 and higher were ok. The warning was 
followed by a segfault. This on a C2D.

I re-compiled without --enable-proc-opt and things worked.


More information about the mythtv-dev mailing list