[mythtv] mythfilldatabase environment requirements [SOLVED]

Robin Gilks g8ecj at gilks.org
Thu Oct 4 21:03:46 UTC 2007

> I'm somewhat stuck with using tv_grab_nz-py in conjunction with
> mythfilldatabase.
> tv_grab_nz-py works great from the command line but running it from
> mythbackend as a scheduled mythfilldatabase activity causes problems which
> may be related to my environment. If I can get some idea of the
> expectations of the grabber/backend combo then perhaps I can fix it!!

I've made a lot of changes so I'm not quite sure what fixed it but I
*think* it may have been something as simple as having the file
permissions on the grabber set to 0744 instead of 0755 so the mythtv user
couldn't execute it :-( Not convinced of that as I upgraded the grabber
(thanks Hads) and I may have messed up the permissions at that point.

Sorry for all the noise, I'll report back in a couple of days when I've
stripped out all the extra environment stuff I hacked in to see if the
execute permissions really was the problem...

Robin Gilks

More information about the mythtv-dev mailing list