[mythtv] [mythtv-commits] Ticket #3317: mythbackend memory leak

Kevin Kuphal kuphal at dls.net
Mon May 7 13:57:45 UTC 2007

Kevin Kuphal wrote:
> MythTV wrote:
>> #3317: mythbackend memory leak
>> -----------------------+----------------------------------------------------
>>  Reporter:  anonymous  |        Owner:  stuarta
>>      Type:  defect     |       Status:  new    
>>  Priority:  minor      |    Milestone:  0.21   
>> Component:  mythtv     |      Version:  head   
>>  Severity:  medium     |   Resolution:         
>> -----------------------+----------------------------------------------------
>> Comment(by Jeremy Green <jaggroups at brownout.com>):
>>  Well, the backend seems to still be using an ungodly amount of memory:
>>  10970 mythtv    15   0 1577m 1.3g  14m S    0 64.0   4:44.61 289m
>>  mythbackend
>>  This less than a day after I started it with --noupnp
>>  So, I don't know how much of the upnp code this disables but it disables
>>  it all then that seems to imply that the problem is elsewhere. Right?
> I'd just like to comment that I too am seeing this behavior on R13352.  
> mythbackend was showing about 1g of RAM after maybe 2 or 3 days of 
> operation.  At this point I started getting problems forking 
> mythcommflag processes so none of my commercial flagging was working.  
> Restarting the backend immediately dropped it down to 262m of virtual 
> RAM.  If there is anything I can do to provide additional data or 
> debugging, please advise.
Just an update.  This is a very consistent problem now.  I can confirm 
that once mythbackend runs for a period of days, the virtual memory 
usage gets above my physical ram (768MB) and things seem to go crazy 
around the same time.  I get messages like this that never resolve until 
I restart the backend

2007-05-07 08:30:33.569 commflag: Commercial Flagging Starting: Clifford 
the Big Red Dog "Who Moved My Bone?; Clifford the Pirateded from channel 
1011 at Mon May 7 08:30:00 2007
2007-05-07 08:30:33.573 myth_system(): Error, fork() failed because 
Cannot allocate memory
2007-05-07 08:30:33.579 commflag: Commercial Flagging Errored: Clifford 
the Big Red Dog "Who Moved My Bone?; Clifford the Pirate ed from channel 
1011 at Mon May 7 08:30:00 2007 (failed with exit status 255)

I didn't find anything generic about a fork error with memory 
allocation.  Is there additional information I can provide to diagnose 
this?  My top shows:

top - 08:56:07 up 6 days, 42 min,  3 users,  load average: 0.10, 0.13, 0.09
Tasks:  97 total,   3 running,  94 sleeping,   0 stopped,   0 zombie
Cpu(s):  1.0%us,  3.0%sy,  0.0%ni, 90.4%id,  4.0%wa,  0.0%hi,  1.7%si,  
Mem:    775856k total,   767484k used,     8372k free,      108k buffers
Swap:   524280k total,   240864k used,   283416k free,   175920k cached

with the backend process

31439 root      18   0  987m 499m  12m S  3.3 65.9  45:08.63 mythbackend


More information about the mythtv-dev mailing list