[mythtv] an update on SVN firewire recordings

Jim Westfall jwestfall at surrealistic.net
Sat Jun 23 18:05:04 UTC 2007

Steven Adeff <adeffs.mythtv at gmail.com> wrote [06.23.07]:
> I've finally finished my move and got my mythtv backend up and running
> again. I've got two DCT6200 boxes daisy chained to one firewire port
> on my motherboard.
> A while back Daniel mentioned commenting a  line out to do a bus
> reset, which I've done. The problem is I still see some recordings not
> working after a bus reset. If I happen to be around and paying
> attention I can run firewire_tester -B, sometimes a few times, to get
> it to work, but the firewire recording code doesn't seem to have the
> same ability?

You dont want to have the reset code enabled if you have 2+ STBs.  It 
resets all devices on the firewire bus, which while fixing one STB it 
will cause the other to break.  You can end up with 2 recorder threads 
fighting trying to fix their STB, but in doing so breaking the other.


> I'm running 13354, so I don't know if this behavior has changed since
> that build. I'm wondering if there is a way to run  something like
> "firewire_tester -B -n %" for the box before each recording until it
> greps "Fix: Success" until someone has the time to look into perhaps
> including the firewire_tester fix/stabilize code into the backend?
> thanks!
> -- 
> Steve
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list