[mythtv] ffmpeg sync

Bruce Markey bjm at lvcm.com
Mon Jun 11 17:46:22 UTC 2007

Janne, I've been using the ffmpeg 8742 resync patch all along
as this clearly resolves MPEG-4 issues. I've retested the MPEG-2
issues I'd mentioned earlier. These may have been resolved by
other commits but I do not see broken frames with live channel
changes and I was able to play 10 out of 10 different DVDs with
no problems. Therefore I'd like to see this committed.

Bruce Markey wrote:
> Janne Grunau wrote:
>> On Tuesday 17 April 2007 20:58:44 Bruce Markey wrote:
>> Updated patch: http://www.grunau.be/ffmpeg_sync_8742_13272.diff.bz2
> I've been using this in production for several days to look
> for MPEG-4 problems and it seems pretty solid. I had tested
> recording a 90min rebroadcast of a College Basketball game
> then playing it back at 3X smooth motion and didn't find any
> broken frames or artifacts. The current SVN did have occasional
> encoding problems in addition to the decode problems you fixed.
> The encoding problems (assumed because the same artifacts would
> appear when played with and earlier frontend) were harder to
> isolate so I never followed up. However, the 8742 patch does
> not have these and this is an improvement.
> I tested the DCT encoding and interlace motion options. These
> do increase the CPU usage though I can't say that I can identify
> a difference in the video. These had been broken in a earlier
> version of myth's ffmpeg but do appear to work in current SVN
> and with this patch. So, MPEG-4 seems to be good.

I've been using these settings for transcodes and while it takes
more CPU time, image quality is still very good at low bitrates. 

> MPEG-2... not so good. If I go to Watch TV and "Y" to an ivtv
> card then press the up arrow to change channels every few seconds,
> about half the time there are broken frame between the old and
> new channel playback. These appear to be broken frame artifacts
> from the old channel before playback starts for the new channel.

In over 100 channel changes, I didn't see this even once again.

> Next, if I hit left arrow, or any other button that will back up
> into the previous channel recorded, the current channel image
> will break up before playback restarts from the other recorded
> file.

Again, I cannot reproduce.

> Next, I tried DVD playback but after trying 4 or 5 DVD, I never
> got one to play a movie though I got a couple to show the vendor
> logos. The screen would remain black at the start of the chapter
> and the console would fill with messages like:
> ...
> [mpeg2video @ 0xb75b3f28]ac-tex damaged at 6 8
> [mpeg2video @ 0xb75b3f28]ac-tex damaged at 6 8
> [mpeg2video @ 0xb75b3f28]ac-tex damaged at 6 8
> ...

Each of the disks I use for testing now start with no decoding
errors. I suspect that applying the the patch may have tickled
a bug but one of the many DVD related changes have resolved the
underlying issue.

--  bjm

More information about the mythtv-dev mailing list