[mythtv] "mythshutdown -t" always giving time in invalid format

Ma Begaj derliebegott at gmail.com
Sat Jun 9 08:56:58 UTC 2007


"mythtshutdown -t" should set the wakeup time to the next recording.

I tried setting wakupe time format i "mythwelcome --setup" to "time_t"
and "yyyy-MM-dd hh:mm:ss", but I always receive the same error.

This gives me "mythtshutdown -t -v all":
2007-06-09 10:51:51.228 MSqlQuery: SELECT data FROM settings WHERE
value = 'WakeupTimeFormat' AND hostname IS NULL;
2007-06-09 10:51:51.228 Mythshutdown: --setwakeup
2007-06-09 10:51:51.228 Mythshutdown: wakeup time given is: 21:53 2007-06-13
2007-06-09 10:51:51.228 Mythshutdown: --setwakeup invalid date format
(21:53 2007-06-13)
                        must be yyyy-MM-ddThh:mm:ss
2007-06-09 10:51:51.237 MythSocket: readyread thread exit
2007-06-09 10:51:51.237 SSDPCache - Destructor
2007-06-09 10:51:51.238 UPnpDeviceDesc - Destructor

I have a feeling that myhtshutdown is ignoring the time format, which
is set in mythwelcome.


More information about the mythtv-dev mailing list