[mythtv] MythTV Multirec Branch...

Simon Levitt maillists at whattf.com
Thu Jul 26 21:56:05 UTC 2007


Hi,

Noticed an issue yesterday: I was attempting to record 3 programs back to back 
on the same channel all with 1min early start and 2min late finish (starting 
at 21:00, 22:00 & 22:40).

The scheduler had put them on virtual tuners 1, 2, then 1 as you would expect 
(all on the same physical card).

The first two recordings worked fine, and the backend was reporting the 
recording of the third (as was my VFD), however it wasn't (to the extent the 
file wasn't even created).

Below is the TVRec prefixed messages from the backend. It was running with '-v 
channel,important'.

2007-07-25 19:58:29.233 TVRec(1): ASK_RECORDING 1 29 0 0
2007-07-25 19:58:30.233 TVRec(2): ASK_RECORDING 2 28 0 0
2007-07-25 19:58:30.233 TVRec(3): ASK_RECORDING 3 28 0 0
2007-07-25 19:58:30.234 TVRec(4): ASK_RECORDING 4 28 0 0
2007-07-25 19:59:02.758 TVRec(1): Changing from None to RecordingOnly
2007-07-25 19:59:02.759 TVRec(1): HW Tuner: 1->1
2007-07-25 20:58:30.289 TVRec(2): ASK_RECORDING 2 29 0 0
2007-07-25 20:58:30.289 TVRec(3): ASK_RECORDING 3 29 0 0
2007-07-25 20:58:30.289 TVRec(1): ASK_RECORDING 1 29 0 0
2007-07-25 20:58:30.291 TVRec(4): ASK_RECORDING 4 29 0 0
2007-07-25 20:59:02.861 TVRec(2): Changing from None to RecordingOnly
2007-07-25 20:59:02.862 TVRec(2): HW Tuner: 2->2
2007-07-25 21:02:00.058 TVRec(1): Changing from RecordingOnly to None
2007-07-25 21:03:00.910 TVRec(1) Error: Failed to set channel to 729. 
Reverting to kState_None
2007-07-25 21:38:30.560 TVRec(1): ASK_RECORDING 1 29 0 0
2007-07-25 21:38:30.561 TVRec(3): ASK_RECORDING 3 29 0 0
2007-07-25 21:38:30.562 TVRec(4): ASK_RECORDING 4 29 0 0
2007-07-25 21:38:30.937 TVRec(2): ASK_RECORDING 2 28 0 0
2007-07-25 21:39:02.092 TVRec(1): Changing from None to RecordingOnly
2007-07-25 21:39:02.093 TVRec(1): HW Tuner: 1->1
2007-07-25 21:39:02.104 TVRec(1) Error: No valid DTV info, ATSC maj(0) min(0), 
MPEG pn(-1)
2007-07-25 21:39:02.104 TVRec(1) Error: Failed to setup digital signal 
monitoring
2007-07-25 21:39:02.104 TVRec(1) Error: Failed to setup signal monitor
2007-07-25 21:42:00.823 TVRec(2): Changing from RecordingOnly to None
2007-07-25 22:22:00.838 TVRec(1): Changing from RecordingOnly to None

Any clues? Anything I can do to help trace it? 

I'm currently running from SVN revision 13918.

Cheers,

Simon.,


More information about the mythtv-dev mailing list