[mythtv] [mythtv-commits] Ticket #2965: ATSC QAM256 channels fail to tune (partial lock) that are working channels with xine and vlc

Jerry Rubinow jerrymr at gmail.com
Tue Jan 23 01:10:55 UTC 2007

On 1/22/07, Daniel Kristjansson <danielk at cuymedia.net> wrote:
> On Mon, 2007-01-22 at 15:31 -0700, Wylie Swanson wrote:
> > On 1/22/07, Wylie Swanson <wylie.swanson at gmail.com> wrote:
> >         Verified working.  Thank you thank you thank you.
> >
> > Hmmmmm.  I take that back, not the 'thank you,' but the verified
> > working part).   I guess I spoke too early.
> >
> > I am still seeing Partial Lock with channels that are known working.
> > I found is that some of the channels that were working before are now
> > not working.  And some of the channels that were not working (KAETDT
> > PBS, for example) are now working.  In each case where the channel
> > never tunes, I see "Signal 70% | (LM_) Partial Lock".  I can tune all
> > of these channels, every time, with the HDHomeRun interface and VLC.
> >
> > Thoughts?  Any additition diagnostic I can provide (a sample of the
> > stream, etc)?
> Hmmm, interesting. Can you try going into mythtv-setup and
> in the input editor enable "Quick" tuning?
> Whether this works or not I would like to see the
>   'mythbackend -v record,channel,siparser' log for one
> working an one failing tune (without "quick" tuning".
> Reopen the ticket and attach the logs, please don't
> cut off the logs early though, exit LiveTV and then
> stop the log. The last time I think the failing portion
> of the log was cut off.

I'm currently having a very difficult time trying to get a DVB tuner
working properly and I'm wondering if it could be related to this or
changeset 12618.  I configured an AverTV HD A180 configured and
scanned the channels and am able to tune properly - with all the
channels still in the 71#1 type format in the database and to
XMLTVIDs.  And I can configure my firewire input to use the same
channel lineup, and everything's good.  However, when I try to map the
channums of the DVB scanned channels to the equivalent channums in the
firewire, it stops being able to tune them, with partial lock
messages, etc, similar (apparently) to what Wylie mentioned.

Oddly, I can revert to an earlier incarnation of my database, and they
play happily together.  But when I remake my card and inputs from
scratch, I run into problems.  I'm running trunk SVN from earlier this
month.  Does it sound like it might be this or some other bug, or does
it sound more like I'm screwing something up?

To give an example, for a DVB chanel, I have chanid 2711, channum
71#1, freqid 71, sourceid 2, mplexid 17, serviceid 1140.  And for the
equivalent firewire channel, it's chanid 2810, channum 810, freqid
810, sourceid 2, atsc_major 810, atsc_minor 0.

This will tune ok to the DVB channel if I go into live tv, and hit Y
to select the DVB tuner.  However if I change channum to 810 and set
the XMLTVID to be the same, I start getting the partial locks when I
go into live tv and try to tune the DVB channel.


More information about the mythtv-dev mailing list