[mythtv] Ticket #2830: ATSC QAM256 scan in mythtv-setup returns no channels.

Daniel Kristjansson danielk at cuymedia.net
Tue Jan 2 21:17:07 UTC 2007

On Tue, 2007-01-02 at 15:20 -0500, R. G. Newbury wrote:
> Daniel Kristjansson wrote:
> > On Tue, 2006-12-26 at 19:36 -0500, R. G. Newbury wrote:
> >> MythTV wrote:
> >>> #2830: ATSC QAM256 scan in mythtv-setup returns no channels.
> >> Sorry, I could not post with the log attached as it is too big for Trac. 
> >> I attempted a posting, and it has been held for the moderator to 
> >> approve. If you know who that is, you may be able to influence that 
> >> decision. I also attempted a direct post to you, with the log attached 
> >> (outside TRAC).
> Hope you had a good Christmas/New Year's break. In the meantime, I fuond 
> that clearing the 'Unencrypted Channels Only' flag allowed a channel 
> scan to complete...at the cost of adding all 454 streams to the channel 
> list!.
Yikes! Well as I said in the e-mail I sent a couple hours ago it looks
like the problem is that your cable operator is marking your unencrypted
channels as if they were encrypted, so this makes sense.

> I (attempted) to take a look at the code, but I cannot figure out where 
> things are...I found the top-level case statement which includes a 
> reference to the 'VideoSourceEditor' function, but I cannot find that 
> anywhere...A full grep of the source produces no hits, nor on 
> 'vse'...How does this stuff work!..
VideoSourceEditor is defined in videosource.h, it turned up in my grep:
grep VideoSourceEditor libs/*/*.{cpp,h}

> Now that I have my system working, the pressure is off a little, but I 
> still want to help track this down. As noted, I have had 2 different and 
> separate reports of this error. Both North American so I may be related 
> to the cable versus OTA divide..
It's more of a cable operator screwing with their customers
kind of thing. But I need to write a A/V stream detector
anyway for the FireWire signal monitor since my SA 4200HD
sometimes rewrites PMTs incorrectly, this should fix the
problem with your cable operator as a side effect..

-- Daniel

More information about the mythtv-dev mailing list