[mythtv] Display Old Original Air Dates?

Martin Long mythtv at longhome.co.uk
Tue Feb 27 19:55:27 UTC 2007

Or, of course, like Bruce said. they could just be zero values where data
wasn't present. D'oh!



From: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-bounces at mythtv.org]
On Behalf Of Martin Long
Sent: 27 February 2007 19:48
To: 'Development of mythtv'
Subject: Re: [mythtv] Display Old Original Air Dates?


Dates and times on 32 processors are often stored as a time_t value. This is
an integer counting the number of seconds since midnight on January 1st
1970. It should be a signed integer, so theoretically dates should be able
to count back from 1970 too. A bug know as the 2038 bug, means that the
integers roll in 2038 (similar to the millennium bug), one considered
resolution to this is to use unsigned integers, making the range 1970 - 2106
(or something like that). Unsigned integers could be the reason that you
can't get pre-1970 dates, or it could alternatively be to do with incorrect
or unimplemented negative number arithmetic somewhere. 


The problem could be in myth, but I suspect the database could have a large
part to play. I don't know a specific fix, but a simple change of column
type in the database MAY be the solution. 





From: mythtv-dev-bounces at mythtv.org [mailto:mythtv-dev-bounces at mythtv.org]
On Behalf Of Tim Musa
Sent: 27 February 2007 15:29
To: mythtv-dev at mythtv.org
Subject: [mythtv] Display Old Original Air Dates?



Maybe this should be a bug ticket, but I figured I'd check here first.
Currently all of my old TV shows (pre-1970) show up with and
%ORIGINALAIRDATE% of 12/31/1969.  This causes the "Sort by Air Date" to not
sort the episodes correctly.  The date is correct in the MySQL database, so
I know the data is correct.  However, somewhere in the display process the
date gets cut off at 1/1/1970.  ID did some playing around with modifying
the date in the database and found that dates display correctly between
1/1/1970 and 1/18/2038.  I'm guessing that this isn't a quick fix, but was
hoping to find out if a fix was possible. 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20070227/d589ebe2/attachment.htm 

More information about the mythtv-dev mailing list