[mythtv] mythtv-vid/opengl compilation issues

Jack Perveiler perveilerj at yahoo.com
Mon Feb 12 16:51:22 UTC 2007

I tried compiling the mythtv-vid branch over the weekend and ran into a couple
of issues related to opengl headers.  I've fixed them for myself, but I thought
I'd post them here in case they're more prevalent and something you want to

Note: I started years ago with KnoppMyth, but once I figured out what I was
doing I tried to undo anything that wasn't debian-stable.

Problem 1: 
The version of mesa I had installed (from debian-stable) is too old and is
missing prototypes.  It installed the GL headers in /usr/X11R6/include/GL.  The
nvidia installer (as run by itself, not installed from a package manager) puts
the newer headers in /usr/include/GL, but /usr/X11R6/include/GL got picked up
first.  /usr/include/ is first in the -I portion of the compiler command line,
but because it's a "standard system include directory" gcc 3.3.6 moves it to
the back of the search path.  I fixed it by moving the old, duplicated mesa
includes out of the path but if this is a common configuration then maybe
you'll want to fix it on the compile command line (with -nostdinc or
-nostdinc++ maybe?)

Problem 2:
The glx.h and glxext.h that the nvidia 8756 installer installs (glx version
1.4) has glXGetProcAddress() guarded by #ifdef GLX_GLXEXT_PROTOTYPES. 
util-opengl.cpp, in get_gl_proc_address(), tries to use it so long as
GLX_VERSION_1_4 is set (it doesn't test against GLX_GLXEXT_PROTOTYPES). 
Changing that line to:


fixed it for me, but I don't know if that's "proper" (maybe the real issue is
that I don't have GLX_GLXEXT_PROTOTYPES set?)

Anyways, after those fixes I was able to build.  If they're unique to something
funky in my system the I'm cool with what I've done, but if what I have is
"typical" for debian stable then maybe this is worth looking into.



TV dinner still cooling? 
Check out "Tonight's Picks" on Yahoo! TV.

More information about the mythtv-dev mailing list