[mythtv] Issues changing PREFIX

Gunnar Strand GStrand at gustra.org
Wed Feb 7 10:38:36 UTC 2007

Nigel Pearson wrote:
>> Yep, it finds /opt/lib:
>> + for x in '$SRCH'
>> ++ cat /etc/ld.so.conf.d/local.conf
>> ++ grep -v '#'
>> ++ grep -v '^include'
>> + LP_APPEND=/opt/lib
>> It ends up in LIBPATHS.
> Aah. So configure is actually finding libmp3lame,
> but make isn't? Sorry. I misunderstood the problem.

My bad, I think I wasn't completely clear about it!

> Try something like LD_LIBRARY_PATH=/opt/lib configure --extra- 
> ldflags=-L/opt/lib

Actually, it's commented out in configure:



After uncommenting and running configure in a clean untar:ed copy I 
still get link errors:

   /usr/bin/ld: cannot find -lmp3lame
   collect2: ld returned 1 exit status
   make[2]: *** [libmyth-0.20.so.0.20.0] Error 1
   make[2]: Leaving directory `/mnt/opt/build/mythtv-0.20/libs/libmyth'

config.mak and libs/libmyth/mythconfig.mak does contain the extra flag:

   LDFLAGS=-Wl,--warn-common -L/opt/lib

but it still doesn't get propagated into the make process.

Kind Regards,


More information about the mythtv-dev mailing list