[mythtv] [mythtv-commits] Ticket #2485: mythmusic segmentation fault, not when running through gdb

Steven Adeff adeffs.mythtv at gmail.com
Thu Sep 28 13:20:07 UTC 2006

On 9/28/06, MythTV <mythtv at cvs.mythtv.org> wrote:
> #2485: mythmusic segmentation fault, not when running through gdb
> ------------------------------+---------------------------------------------
>  Reporter:  vbrunini at mit.edu  |       Owner:  ijr
>      Type:  defect            |      Status:  new
>  Priority:  minor             |   Milestone:  unknown
> Component:  mythmusic         |     Version:  0.20
>  Severity:  medium            |
> ------------------------------+---------------------------------------------
>  I'm experiencing occasional, random segmentation faults in MythMusic.  I'm
>  currently running the 0.20 release version of mythtv and mythplugins.
>  The segfaults seem to be occurring when starting a new track. Sometimes it
>  happens right when I enter mythmusic, sometimes it plays fine for hours
>  before segfaulting.  All of this is while playing in random shuffle mode,
>  I'm unsure whether any other shuffle modes have the same problem since I
>  rarely use them.
>  Initially I thought that I might have one or two corrupted tracks that
>  caused segfaults when mythmusic tried to load them, but I went through my
>  entire collection today and all of them started playing fine.
>  Unfortunately while running mythfrontend through gdb in an attempt to get
>  a backtrace I've been unable to replicate the segfault. I'll leave it
>  playing the rest of tonight and all of tomorrow to make sure, but it seems
>  that running through gdb prevents the random segfaults.
>  I know the lack of a backtrace will probably make this very hard to debug,
>  what other information can I provide to help? Other than this one problem
>  mythtv is rock solid stable, and the system has been up for over 29 days
>  now so it is not a faulty RAM problem.

try the
ulimit -c unlimited
method. its worked well for me when running through gdb seems to "fix"
the problem...
for example, in my .xinitrc file I have,

ulimit -c unlimited
mythfrontend -v all,nodatabase -l /var/log/mythtv/mythfrontend.log

Before you ask, read the FAQ!
then search the Wiki, and this list,
Mailinglist etiquette -

More information about the mythtv-dev mailing list