[mythtv] 'WriteAudio: buffer underrun' during playback caused bythe scheduler

William Prochazka billprozac at gmail.com
Thu Sep 14 02:01:07 UTC 2006

So I am reading this thread I found through Google that sounds just like my
issue, come to find out it is an active thread and I just had not check the
Dev grou pin a few days ;).  Ok, so I have a P4 3.0HT w/ 1GB of ram and an
NVidia FX5200.  I( am trying to output the HD using DVI and the audio
passthrough to my receiver.  Like Jan, I am getting no great results.  I
have tried using XvMC, but I see a 87-90% CPU usage yet the audio and video
are very skippy.  The receiver detects the audio as 3/2 which is fine.  As
far as skipping, though, I hear .5 sec of audio and the .5 of silence and
the video is skipping in-time.  Without XvMC, I am getting 99% CPU
utilization but only occasional skipping (ie, when there is lots of
motion).  Of course if I dare to add in any type of deintelace it gets
worse.  I have tried disabling HT thinking it might be a CPU task switching
issue (plus HT doesn't really DO that much), real-time priority, and any
other tweak I can think of.  I am very intrigued by your mention of
additional audio buffers, but where would you put them?  My .asoudrc looks
like this:

pcm.fixed {
type plug slave {
pcm "spdif"
rate 48000

pcm.!default {
type plug
slave.pcm "spdif"

Which was to fix audio sampling rate for  passthrough.

Is there anything that needs to/can be done to tweak XvMC, or is it all or

Also, you mentioned that you have moved to a Dual Core CPU.  Which chip, and
what kind of CPU utilization are you seeing?


On 9/13/06, Mark Spieth <mark at dclabs.com.au> wrote:
> > Sorry, the other way round: 'ALSA:default' comes back to live,
> '/dev/dsp'
> > dies...
> >
> >Jan Kleinig schrieb:
> >Got it working now using 'Video timing method: RTC', but I still have the
> >same probs... I found out that using >sound device 'ALSA:default' does
> end
> >with no sound and a lot of 'WriteAudio: buffer underrun' in the log,
> >while
> >using '/dev/dsp' stumbles with the picture and logging the same
> >'WriteAudio: buffer underrun', but it >comes back to live after about 2
> >seconds...
> is this in 6 channel mode or 2 channel mode? if in 6 ch mode can you try
> the
> same thing in 2 ch mode
> when I tested it seemed ok in 6 channel mode. doesnt mean there is nothing
> wrong though.
> I have to find time to test this again. weekend hopefully
> cheers
> mark
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-dev/attachments/20060913/ed3bf92d/attachment.htm 

More information about the mythtv-dev mailing list