[mythtv] "ivtv driver has stopped responding" - with diff

jrandall at ftrd.us jrandall at ftrd.us
Thu Oct 5 04:42:59 UTC 2006

Did this patch make it in to 0.20, because I am running 0.20 and am  
having this problem occasionally with my PVR-500.  Interestingly,  
when this occurs, mythbackend also stops responding to the front end,  
and the mythfrontend output says "Unexpected response to  

The only thing I have been able to do to recover from this problem is  
to restart the back end.


On Feb 13, 2006, at 6:09 PM, Isaac Richards wrote:

> On Monday 13 February 2006 18:05, Derek Battams wrote:
>> Ok, this finally happened again today while watching live tv.  And my
>> fix worked.  On the select timeout, the device was closed, reopened,
>> and recording continued.  I only lost about 1-2 seconds of the
>> recording, but then it continued with no problems until the end of  
>> the
>> program.  I'd like some feedback on this before I go opening a ticket
>> for this.  I think the more interesting issue is why this timeout
>> occurs during a recording in the first place.  I wasn't able to  
>> find an
>> explanation for this so this patch is the next best thing I could  
>> come
>> up with and, most importantly, it works by allowing an in-progress
>> recording to continue instead of just dumping the printf over and  
>> over
>> until the program ends.
> Patch looks fine.  Don't really need the long comment, though. =)
> Basically, when this happens, the ivtv driver has stopped giving us  
> data.
> Nothing much we _can_ do aside from close + reopen the device like  
> you're
> making it.
> Isaac
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list