[mythtv] [mythtv-commits] Ticket 1802

Matthew Wire devel at mrwire.co.uk
Mon May 29 15:16:26 UTC 2006

On Mon, 2006-05-29 at 10:38 -0400, Michael T. Dean wrote:
> On 05/29/2006 06:37 AM, Matthew Wire wrote:
> > On Mon, 2006-05-29 at 07:37 +0200, Leo Weppelman wrote:
> >   
> >>>  This breaks mythgallery for me.  With a DVD-video in the drive I can no
> >>>  longer exit the gallery.  MythTV starts up and "handles" the dvd using
> >>>  mythgallery.
> >>>  1. I get an iconview showing audio_ts and video_ts.  2. When I press
> >>>  escape i get Gallery and [DVD_NAME].  This continues in an endless loop
> >>>  and there is no way of exiting the gallery.
> >>>  Before this patch was applied everything worked correctly.
> >>>       
> >> Your basic problem is probably in your fstab entry for the dvd, the dvd is
> >> handled as a data-dvd not a 'real' dvd. I guess you are missing the 'udf'
> >> part...
> >> My fstab entry:
> >>   /dev/hdc   /media/cdrom0   udf,iso9660 ro,user,noauto,uid=mythtv
> >>
> >> Where the endless loop is coming from, I have not idea.
> >>     
> > Nope.
> > My fstab entry is:
> > /dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
> But if you have all lowercase audio_ts and video_ts (as you said you 
> did), the DVD is definitely mounted as an iso9660 filesystem--regardless 
> of the preference specified in fstab.  If mounted properly as a udf 
> filesystem, they'll both be all uppercase.
You are correct, looking at my mount list the dvd is mounted as an
iso9660 device.  I don't see anything wrong with this? (By the way,
using Ubuntu Dapper).
On a semi-related issue I've just submitted a patch to mythcdrom.cpp
(#1892) to test for video_ts as lowercase as well as uppercase.

But the gallery is still not working for me (it did before the fix):
Test1: dvd in drive, start mythfrontend.
Expected: myth goes to play dvd screen.
Actual: myth opens gallery.
Correct?: NO

Test2: start mythfrontend, insert dvd in drive.
Expected: myth goes to play dvd screen.
Actual: myth goes to play dvd screen.
Correct?: YES

Test3: insert cd with images, start mythfrontend.
Expected: myth opens gallery with cd.
Actual: myth opens gallery with cd.
Correct?: YES

Test4: start mythfrontend, insert cd in drive.
Expected: myth opens gallery with cd as root.
Actual: myth opens gallery with cd as root.
Correct?: YES

OK. So test1 is probably something to do with the order of
initialisation, this is a separate issue that I'll try and investigate.
However, for all 4 tests the same thing happens when gallery is open:
1. Root directory of CD is display.
2. If I press Escape I get two entries - Gallery and CD(name of cd)
3. If I press Escape again I get (1).
4. Opening subfolders works correctly, but as soon as I escape enough
times, I get (2) followed by (1) in an endless loop.

Thanks for your help, I hope we can get to the bottom of this!

More information about the mythtv-dev mailing list