[mythtv] HD3000: Could not get card info for card #0!

Robert LeBlanc robert at leblancnet.us
Tue May 16 13:44:16 UTC 2006

I didn't have problems. I remove the deb package, but did not purge it
to keep the database and then installed the custom compiled version and
everything stayed. This was almost a year ago with 0.18 though.

Robert LeBlanc

> -----Original Message-----
> From: mythtv-dev-bounces at mythtv.org
[mailto:mythtv-dev-bounces at mythtv.org]
> On Behalf Of David Cain
> Sent: Monday, May 15, 2006 5:53 PM
> To: mythtv-dev at mythtv.org
> Subject: Re: [mythtv] HD3000: Could not get card info for card #0!
> At 12:00 PM +0000 5/14/2006, Daniel Kristjansson
<danielk at cuymedia.net>
> wrote:
> >On Sat, 2006-05-13 at 00:23 -0400, David Cain wrote:
> >> Sorry for having to ask this on the Dev list, but I've tried
> >> MythTV-User twice, searched the archives and the web and don't have
> >> answers. Have been stalled at this point for about a month and
> >> you folks might recognize these symptoms.
> >> I note that I couldn't compile some of the dvb-tools in an earlier
> >> attempt - they too said something about frontend (and 'FE_ATSC' -
> >> "FrontEnd"?) Anyone got any ideas here?
> >
> >This is probably the culprit, my guess is that if you run
> > locate frontend.h | grep dvb
> >it will return more than one set of headers, probably one
> >in /usr/include/linux/dvb, and another in your kernel.
> Yep. Found 'em.
> >MythTV uses the one in /usr/include, unless you tell it
> >otherwise in ./configure with the "--dvb-path=" directive.
> >In your case I'm betting the headers in /usr/include don't
> >include support for ATSC. There are two options, upgrade
> >your system so that the headers in /usr/include are up to
> >date, or point --dvb-path to the kernel's include directory,
> >but this may or may not work (which is why there is a
> >cleaned up, multi-kernel compatible copy in /usr/include).
> >
> >> Is the issue that I've only installed mythtv-backend and
> >> mythtv-database on this machine?
> >
> >It should be fine so long as you compiled the libraries without
> >--disable-frontend. But you may as well install the whole thing
> >until you have that working, and then get rid of the stuff you
> >don't need. So you don't accidentally remove essential bits.
> This is just the rub: I haven't compiled (well, MythTV anyway...). I'm
> using Marillat's (very thoughtfully provided) .debs. Am I to assume
> there's
> a problem with the .debs? Seems like Marillat mightn't have caught the
> lack
> of ATSC stuff from France.
> I guess my solution is to replace the stock DVB frontend.h file (done)
> compile MythTV 0.19 from scratch, yes? Have never been able to
> successfully
> complete compiles of 0.18, so I'm not holding out much hope here.
> Should I replace all the other DVB-specific .h files with copies from
> --dvb-path?
> Any Debian experts know whether I'll be able to overwrite my own
> of
> 0.19 with (hopefully-working-for-ATSC) debs of the next version
> problem?
> Thanks for the help and the response,
> DC
> --
> ------------------------------------------------------------
>              ==  E  C  N  A  L  U  B  M  A  ==
>              http://www.jimmiedave.com/
> ------------------------------------------------------------
> _______________________________________________
> mythtv-dev mailing list
> mythtv-dev at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-dev

More information about the mythtv-dev mailing list