[mythtv] XvMCTex: Init failed

Robin Gilks g8ecj at gilks.org
Sat May 13 11:39:46 UTC 2006

>>Trying to use the internal DVD player on an Epia SP13000 and I hit this
>>XvMC  problem in r9924. Here is the output from ./configure and standard
>>log output - I can capture more log detail if someone can tell me what to
>>switch on!
>>./configure --compile-type=debug --disable-audio-jack --enable-xvmc-pro
>>--enable-xvmc --cpu=i686 --enable-mmx --disable-dbox2
>># Basic Settings
>>Compile type     debug
>>Compiler cache   no
>>DistCC           no
>>Install prefix   /usr/local
>>CPU              x86 (i686)
>>Big Endian       no
>>MMX enabled      yes
>>Vector Builtins  yes
>># Input Support
>>Joystick menu    yes
>>lirc support     yes
>>Video4Linux sup. yes
>>ivtv support     yes
>>FireWire support no
>>DVB support      no [/usr/include]
>>DBox2 support    no
>>HDHomeRun sup.   yes
>># Sound Output Support
>>OSS support      yes
>>ALSA support     yes
>>aRts support     no
>>JACK support     no
>>DTS passthrough  no
>># Video Output Support
>>x11 support      yes
>>xrandr support   yes
>>xv support       yes
>>XvMC support     yes
>>XvMC VLD support yes
>>XvMC pro support yes
>>XvMC OpenGL sup. no
>>XvMC libs        -lXvMCW
>>Mac accel.       no
>>OpenGL vsync     no
>>DirectFB         no
>># Misc Features
>>Frontend         yes
>>Backend          yes
> I am also running an EPIA SP1300 and have a very different config.
> Specifically, configure detects the xvmcpro libraries. This may well have
> nothing to do with any problem you are having, of course...
> ./configure \
>         --prefix=/usr/local/mythtv.SVN \
>         --compile-type=release \
>         --enable-proc-opt \
>         --enable-dvb --dvb-path=/usr/include \
>         --disable-ivtv --disable-dbox2 --disable-hdhomerun \
>         --enable-xvmc --enable-xvmc-pro \
>         --enable-xrandr --enable-x11 \
>         --disable-opengl-vsync
> # Basic Settings
> Compile type     release
> Compiler cache   no
> DistCC           yes
> Install prefix   /usr/local/mythtv.SVN
> CPU              x86 (model name        : VIA Nehemiah)
> Big Endian       no
> MMX enabled      yes
> Vector Builtins  yes
> # Input Support
> Joystick menu    yes
> lirc support     yes
> Video4Linux sup. yes
> ivtv support     no
> FireWire support yes
> DVB support      yes [/usr/include]
> DBox2 support    no
> HDHomeRun sup.   no
> # Sound Output Support
> OSS support      yes
> ALSA support     yes
> aRts support     yes
> JACK support     no
> DTS passthrough  no
> # Video Output Support
> x11 support      yes
> xrandr support   yes
> xv support       yes
> XvMC support     yes
> XvMC VLD support yes
> XvMC pro support yes
> XvMC OpenGL sup. no
> XvMC libs        -lviaXvMCPro
> Mac accel.       no
> OpenGL vsync     no
> DirectFB         no
> # Misc Features
> Frontend         yes
> Backend          yes

Just tried running configure from the chroot environment for the Epia and
I get the same result as you do once I move the XvMCW libs out of the way.
I generally build mythtv on my main server and then chroot into the nfs
mountpoint for the diskless SP13000 and then just do a 'make install' of
the already built binaries. Could be that that is a bad move but
everything has worked OK on the two machine I run it on without problems
by using the wrapper for either the Nvidia or Via XvMC libs.

Do you get the Internal DVD player to run OK on current SVN? It certainly
something to do with the XvMC libs as I can sort of run it in a stuttery
way on the Epia using the libmpeg2 decoder and a couple of months ago it
ran fine as well...


Robin Gilks

More information about the mythtv-dev mailing list