[mythtv] Building 0.20svn on MacOS x86? Change reverted

Todd Ignasiak ignasiak at gmail.com
Wed Jul 19 04:04:12 UTC 2006

On 7/18/06, Isaac Richards <ijr at case.edu> wrote:
> On Tuesday 18 July 2006 2:01 pm, Todd Ignasiak wrote:
> > I just tried to build 0.20 svn, after seeing that the patch to fix the
> > menus was committed (menus failed for me in previous builds, and work
> > great now).
> >
> > Everything looked good until I tried to play a video, where I got a
> > crash in the YUV4200to2VUY
> > function.   This same crash happened way back in early attempts to
> > build on x86, so I looked back at that change and it appears that the
> > fix that was previously committed to 0.20 svn has been reverted.  So,
> > now the conversion routine is set to NULL when altivec is not
> > available.   The change before defaulted to a non altivec routine.  (
> > shown here: http://www.mythtv.org/wiki/index.php/Myth_on_Mac_x86 )
> >
> > I'm not sure if this is related to ticket 1572, or some other
> > problem..  I couldn't find an answer in the commits ML.    Is there
> > some reason it was removed, am I overlooking something, or is this an
> > error?
> If something was never committed in the first place, how could it be reverted?

Hmm..  My mistake I guess.

After manually adding that modification, 0.20svn plays video fine on
my Core Duo Mini.

More information about the mythtv-dev mailing list